WordPress.org

Forums

Can't login as admin? (7 posts)

  1. RhunDraco
    Member
    Posted 10 years ago #

    Greetings everyone,

    I just installed WP, and I can't seem to login as the admin user that gets created. When I enter admin as the user and the random password given, clicking the login button just redirects me back to the login screen, with no errors.

    before: ~rhun/wordpress/wp-login.php
    after: ~rhun/wordpress/wp-login.php?redirect_to=%2F%7Erhun%2Fwordpress%2Fwp-admin%2F

    Is this a problem with my apache setup?

    Thanks!

  2. Mumble
    Member
    Posted 10 years ago #

    If you have access to PHPMyAdmin, can you go to the WordPress database that was created, and then to wp-options? Check if the siteurl value points to the correct URL. I seem to recall this as the cause for my own problems with installing WP.

  3. RhunDraco
    Member
    Posted 10 years ago #

    hmm, I looked at the db and I don't see anything for the siteurl.

    I had WP working on this server several months ago, and there were no issues. However, this is a newer install of slackware and apache. I'm wondering if there isn't something different that I did in the setup.

  4. RhunDraco
    Member
    Posted 10 years ago #

    Ok. Here's something. I run Apache w/SSL and I always connect to my server over https. Well, it appears that if the siteurl is an https link, it won't let me in. I switched back to using standard http to connect to my server (I run apache on a non-standard port, so I have to specify the port), it allows me in with no problems.

    After logging in as admin, I modified the siteurl values in the options page to reflect the https url, and guess what? I can no longer log in. So, there seems to be an issue with WP not being SSL friendly??

  5. Mumble
    Member
    Posted 10 years ago #

    I'm not familiar with SSL, and can only recommend a forum search for "https", through which I found a few posts that might help you, for example this one:

    http://wordpress.org/support/topic.php?id=6888

  6. kayro
    Member
    Posted 10 years ago #

    I have this problem too and i can't fix it

    help please

  7. tparlin
    Member
    Posted 10 years ago #

    This is the exact same problem that is described here, I'm not sure what's being done about it though.

    http://wordpress.org/support/topic.php?id=20374

    Some people posted possible fixes that you could try...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.