Support » Installing WordPress » Can't login after migration

Viewing 15 replies - 1 through 15 (of 17 total)
  • It is caused by the white space that was created while editing php files. In this case, I think it should be your config.php file. Browse down to the bottom and place your cursor between the last ? and > and press the delete key at least for 15 seconds. After that retype >. This should solve the problem.

    Hello Krishna,

    Thank you for your answer!
    I tried that exactly like you suggested (@ wp-congig.php) but no changes.

    Generally speaking – Can hidden white spaces occur, which are not visible in editors like Notepad or Weaversleaver?

    Please read these instructions:
    http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F .

    Try to follow the instructions, and report back. Then I will tell you what to do next, if you cannot solve it. Most probably you will succeed.

    Use only plain text editors like NOTEPAD. Do not use software like MS Word or anything like that. Being empty spaces, they are not visible. They can be in the beginning as well as at the end. Once you do the DELETE process, you should only type > at the end and < at the beginning. Do not touch any other key after that.

    I am using wordpad.

    according to the error message the trouble should be caused by the first line of wp-config.php –

    “Cannot modify header information – headers already sent by (output started at /var/www/web551/html/MYFOLDER/wp-config.php:1)”

    I tried to delete all white spaces in the first line…but no changes.

    I actually did not have “?>” on the very end of wp-config.php.
    I added it (thought I might have deleted it by accident during the long process of trying to solve this issue), but now I copied it again from a fresh install and figured out, that also in the new wp-config.php I can’t see “?>” at the very end.

    do I misunderstand something very basic?

    am using wordpad.

    That is not a plain text editor. Use Notepad.

    I actually did not have “?>” on the very end of wp-config.php.

    That is correct. It has been deliberately omitted.

    i use notepad of course, never wordpad.
    sorry, my mistake to mention wordpad.

    @ Krishna

    I went through this instructions, but it didn’t solve the issue.

    I am using a re-direction (via domain-tool on the webserver) from root to “MYFOLDER” (where wp-is installed).

    from the tutorial you sent me –

    “Other issues that might cause that error:
    (…) Instead use javascript redirection if needed.”

    could it be an issue with re-direction?

    Can you post here your Site URL?

    hello krishna, may I PM it? it’s a company website and therefor a bit delicate.

    Sorry that is not allowed here. You may better hire someone here

    I’d rather like to solve it with the help of the forum as this is nothing i get paid for. I’ve several wordpress-pages for my own art-projects and if i will have to migrate one of this projects once, I would also love to understand how this works, or can be trouble-shooted if something goes wrong.
    any other possibility which comes to your mind?
    thank you very much for the attention you give to this issue!

    I copied all content to the root-directory and the error message stays exactly the same.

    if it is not an issue with white spaces @ wp-config.php on line:1 (which I checked now 10.000 times already) with notepad and php-editors, does somebody know what the heck else could cause this trouble????

    Thanks for any help!

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/web551/html/MYFOLDER/wp-config.php:1) in /var/www/web551/html/MYFOLDER/wp-login.php on line 349

    When you have an error message like this, the first possibility is that the white space is caused by config.php. If it is not there, you have to check the second file wp-login.php. Like his you have to check the other core php files also mentioned in the warning.

    You get this message because the browser gets blank/ white space when the browser sends a request to your server.

    That is one part. Because you cannot locate the cause of the issue, you can try several other things like reinstalling WordPress with a fresh downloaded copy, turning off all your plugins and reverting to your default WordPress theme, etc. I do not know what all checks you may have done already.

    You are running an old version of WordPress. The plugins that you are using or the theme that you are using may not be compatible with the old WP version. There are several other issues like these that you have to check.

    Yet another possibility can be malware/ virus infection, etc. You may check it also.

    Krishna, thank you. The thing is – The same page runs on the previous location (from where i migrate) without troubles. same webhost, same server-settings, same wordpress-version, same php version, same plugins and as it’s a direct copy from the database as well as from the files, I there shouldn t be a virus involved either. slowly I’m going insane with that question:D
    I will check one last time all the files and try to find this bloody white spaces and if it doesn t work re-program the whole page. a reasonable tool for migration would be indeed very useful, cause that’s a nightmare.
    anyway thank you so much for your detailed explanation, I’ll check if i overlooked something and greetings to the wonderful New Delhi!

    You are welcome! Report back if you face problems. If I am not available, someone else will reply to your questions.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Can't login after migration’ is closed to new replies.