Support » Fixing WordPress » can’t login..

  • i can’t login to wordpress.. there is only one user, me. when i enter the correct user/pass i press the submit button and i get a brand new login page right back. if i use an incorrect password, it tells me so. if i use an incorrect username, it tells me so. but if i use the correct info it just spits out a blank login page with no error message.
    it worked a week ago. i dont think i changed anything. any ideas?
    anthony

Viewing 15 replies - 1 through 15 (of 40 total)
  • Moderator James Huff

    (@macmanx)

    Moderator James Huff

    (@macmanx)

    That’s only if you have a secure HTTPS server. Most webhosts offer it, but for an additional price. If you do have a secure HTTPS server, then you can change your URL in Options/General.

    Moderator James Huff

    (@macmanx)

    Also, not in the FAQ list, but you may want to try uploading a fresh copy of wp-login.php, just in case something became corrupt.

    Yeah, I did upload a new copy. I edited the one in the 1.2 folder that was on my computer, then uploaded that.

    thanks for the FAQ link. sorry i didnt see it beforehand. however- it still doesnt seem to be working. i’m not the most experienced computer user, but heres what i did, and the information i believe you wanted if it didnt work:
    i did steps 1, 2. step 3 needed no changes. did step 4. step 5 not relevant to my setup, i think. did step 6.
    now the login page is changed a bit, which i assume is from the new sexygirlgeek code, but the problem is the same: if i login with the correct info it spits me back to a blank login page. if i enter incorrect login info, it tells me there was an error and gives me a blank login page.
    i am running xp home edition, with IE 6.0.2800 (?). wordpress 1.2.1, i believe. im not sure what server info you need, but heres a smattering, and let me know if there is something i left out- server runs linux; php version 4.3.8; mySQL version 4.0.22-standard;
    one question- i have only one user set up. it was unclear to me from step 4 whether i was being instructed to setup an additional user named ‘admin’. i assume my current username is the admin, but correct me if im wrong. pardon my ignorance.
    thanks,
    anthony

    Moderator James Huff

    (@macmanx)

    Hm, take a look at this post: http://wordpress.org/support/3/17366
    Could it be a plugin that’s causing the trouble?

    If you have cleared your cache and restarted your browser, but still can’t log in.
    And you are using either WP1.2.1 or WP1.3
    then maybe this will help:
    http://fernando.dubtribe.com/archives/2004/12/05/turnip-cant-log-in-lost-css-what-the-heck/
    please be sure the above conditions are true before you go whacking about in your wp files.
    F.

    Anthony: I would look at the link mac gave you. Even though I don’t have your problem, I looked at it, and it seems like what you have.
    As for the different-looking login page, I had that too. Once I did step 3, I uploaded the page and it was missing the WP logo. Then I copied and pasted sexygeekgirl’s code and uploaded that, and there was no change. Is this your prob? It bothered me (darn my love for aethetics!) so I added the logo above the login/password links, and it looked just fine. *shrug* You can change the entire login page’s look, if you’d like.

    umm.. no doubt this is partly due to my computer-incompetence, but i still can’t make her work. i did not install any plugins, so i assume that the media plugin mentioned previously is not at fault. i checked out the fernando link, but it doesnt seem to be relevant to me- when i edit the login.php file the bit of code fernando says to delete is not there. when i check out the site URL in the database it is correct.
    what next?
    anthony

    i realized why that bit of code wasnt there- i was using the sexygirlgeek code. i tossed that, uploaded a new login-php file, and deleted the code, just to be sure. no go.

    xnoobletx – if thats Safari youre logging in with, try deleteing the cookies for your domain.

    Moderator James Huff

    (@macmanx)

    If you wouldn’t mind turning on registration and posting the URL of your blog, we could register and then attempt to log in. That would give everyone a better idea of what’s going on.

    Moderator James Huff

    (@macmanx)

    Registration works. It’s that blasted reload problem. Try replacing BOTH wp-login.php AND profile.php (in wp-admin). And, by replacing I mean delete the old file, then upload a new one from a freshly downloaded WordPress. http://wordpress.org/download/
    If that still doesn’t work, save all the files to your hard drive for backup purposes, then replace every file except the ones you made modifications too (index.php, wp-layout.css, and wp-config.php are the usual ones).

    nope 🙁 i’m still getting the same thing.. *sigh*
    do i have to reinstall the whole package?

    Moderator James Huff

    (@macmanx)

    Probably, but as long as you don’t over-write any files that you made changes to, you won’t lose anything. All of the post data and settings are stored in the MySQL database (which reminds me, DON’T run install.php after you upload the replacement files). You could also hang out and wait for v1.2.2, which may be coming soon, or may not.

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘can’t login..’ is closed to new replies.