Support » Fixing WordPress » Can't log into dashboard

  • I have a wordpress site that is on my localhost. I uploaded/copied all of the files for the site into a folder on my account at fatcow. i also created and imported the database for the site using phpMyAdmin from the cp at fatcow. The site appears and functions exactly as it should:
    http://www.openrangeimaging.com/Test/helitrax/

    The problem is I cannot log into the WordPress dashboard. I have tried resetting the password and still no luck. I keep getting the following error message:
    You do not have sufficient permissions to access this page.
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Can anyone advise me on what might be the problem? Should I have dome a new wordpress install versus copying all the files from my local host?. Like I said the site appears and functions perfectly, just can’t get logged into the dashboard. Any help much appreciated.

    Thank you.

Viewing 15 replies - 1 through 15 (of 25 total)
  • Hi,

    I think you mis-understand my question/problem. If I wanted to log into the the wp dashboard for the site in question I wold use
    http://www.openrangeimaging.com/Test/helitrax/wp-admin.

    I know how to log in. The problem I’m having is that the log in does not work. See my first post above.

    But thanks for trying to help.

    esmi

    (@esmi)

    Forum Moderator

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    Hi esmi,
    Thanks for those trouble shooting suggestions.
    I tried renaming the current-theme to -old and I tried renaming the plugins folder to -old.
    Unfortunately no luck with that.
    Renaming the current theme folder made the site not appear at all.
    Renaming the plugins folder results in getting the same server error as before.

    still can’t log into dashboard but site works fine otherwise. Stumped.

    esmi

    (@esmi)

    Forum Moderator

    Re-upload a fresh, unpacked, copy of the Twenty Eleven folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/extend/themes/twentyeleven

    still can’t log into dashboard but site works fine otherwise.

    I am not seeing what you are seeing then. I get a page with a zero when I go to your link?

    ok I’m trying what esmi is suggesting.

    racer x – I’m working on a variety of replacing folders, re-installing etc so the site is temporarily returning the zero.I’ll post here after I’ve tried these various things.

    thanks!

    Hi,

    Unfortunately I am still stuck. I tried doing a complete new install of wordpress. I was able to log in to the dashboard of the new wordpress install. Next I replaced the wp-content folder with the wp-content folder form the localhost version I have. Next I imported the SQL database from my localhost.

    Same result. The site loads and functions correctly. I even have the wp-admin bar at the top of the screen and it has my user name displayed on the right hand side and shows me as logged in.

    Not sure if this provides any clue but. The admin bar also shows the site name on the left hand side, but under the site name I only have Dashboard as an option. The Themes, Customize, Widgets,Menus choices are not there. Also the Edit Page and +New links are missing from the admin bar.

    I just can’t figure out whats wrong. Seems like some little glitch somewhere but ….where? Thanks for your ongoing help!

    esmi

    (@esmi)

    Forum Moderator

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called “wp_capabilities” for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";s:1:"1";}

    Hi esmi,

    I tried your suggestion. Sorry, but I’m still getting the same reults and error message.

    I very much appreciate your help!

    esmi

    (@esmi)

    Forum Moderator

    How many admin users do you have in your database?

    there are 4 admin users.

    wild guess on my part. this is copied from the wp-config. Could this have something to do with this?

    Another wild guess is some kind of htaccess issue with the host (fatcow)?

    thanks again for your ongoing effort to help!

    oops , I meant to include the code from the wp-config. here it is in reference to my first wild guess above

    deleted code per advice from racer x

    Be careful with what you display from wp-config.php.

    Can you try logging in as any of the other admins? It looks like you are logged in as a subscriber.

    I tried logging in as one of the other admins. Same result/error message.

    Thanks for your ongo9ing effort to help!

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Can't log into dashboard’ is closed to new replies.