Can't log in to wp-admin after updating to wordpress 3.8 - Cookies error (26 posts)

  1. Percolated Propaganda
    Posted 2 years ago #

    Hi All,

    I have developed several custom themes for WordPress using Mamp, Phpmyadmin and Dreamweaver on a Mac and until now I have never had any problems. I started working on a new site yesterday and noticed the wordpress 3.8 update. I updated the site I was working on and several others at the same time. Everything seemed fine until I went to log in today and I get this error:

    Cookies are blocked or not supported by your browser

    Cookies are enabled and I have tried it in several different browsers but the same thing happens. I have tried commenting out lines 744 to 746 in the wp-login file containing the if else statement about testcookies but I just get a blank white screen after logging in.

    The wierdest thing is that only some of my sites are effected whilst others are fine. I have tried all day to figure this out but I am totally stumped. Any help would be really appreciated.

    Many Thanks

  2. Percolated Propaganda
    Posted 2 years ago #

    Update on problem:

    I have just uploaded the same theme to a live domain and updated to WordPress 3.8 and the login seems to be working fine there. It just gives me the cookies error when I use exactly the same files on my localhost testing server????

    I am assuming this has something to do with the domain name being http://localhost:8888/site instead of http://www.site.com but it has never been an issue before.

  3. maegale
    Posted 2 years ago #

    I am not a developer but the same thing happened to me. Did you ever find a way around it? How can I solve this? Please let me know via this thread or email mae.gale [at] gmail.com

  4. maegale
    Posted 2 years ago #

    I've tried clearing my cookies and enabling them and still nothing. PLEASE HELP!

  5. Percolated Propaganda
    Posted 2 years ago #

    I'm afraid I didn't find a solution, I have just been developing the sites live and not using MAMP.

    Are you using a testing server or can you just not log in to your wordpress site?

  6. mommaroodle
    Posted 2 years ago #

    I'm experiencing the same problem too - but only on my localhost, on my server i can still login

  7. davethedrummer909
    Posted 2 years ago #

    I just tried using clean version of WP 3.8,
    took the wp-login.php file and replaced my sites wp-login.php with it and that did it for me, not sure why. Something to do with the way my cache and security plug ins had written to it I think?

    I had moved servers, from one Plesk VPS to another using the Plesk migration tool, there must be something slightly different between the 2 environments in some way ( the IP for starters ), and it set off the security alarm bells...possibly....

    anyway it solved the issue...

  8. p.valente
    Posted 2 years ago #

    I am using WP 3.8

    I created my website at a localhost. Now I moved it to a live host.
    Just found that I can not login anymore. My login page just refreshes giving me no error. The solution of changing password does not at all. I tried the obvious solution of "lost your password?" but I do not receive any email. I changed password via phpMyAdmin but it still refuses to login. I tried the emergency.php script too. This time I received the email saying that the password had been changed (in fact I kept the same) but it did not work either.

    I replaced wp-login.php by a fresh one. It did not result.
    I renamed the wp-content/plugins as wp-content/1.plugins and created an empty wp-content/plugins as suggested for an older WP version (a 5 year old post on a similar problem). It did not result.

    I think this is not a password problem.

    Any sugestions?

  9. Meqs
    Posted 2 years ago #

    Exactly the same problem here :-(

    Tried everything I could find anywhere about this problem, nothing works.
    Only got from error to blank page.

    Could it be a MAMP thing? I use the regular version, not Pro

    I am relatively new at WordPress (all of this coding stuff),
    but if I cant login, how can I ever learn :-s

    Please help...

  10. p.valente
    Posted 2 years ago #

    I just solved my problem.
    The trouble was caused by the plugins.
    I followed a thread posted some time (years?) ago, which suggested to rename (through ftp or ssh) the wp-content\plugins\ directory as wp-content\pluginss\.
    This way the plugins were desactivated and I was able to login.
    after I logged in, and while I was logged in, I renamed back the directory, i.e. from wp-content\pluginss into wp-content\plugins, and I reactivated the plugins one by one in the WP dashboard. It was also necessary to activate the header image as for some reason this had also been desactivated (and this was preventing an easy edition of the pages).

    Now everything is working just fine.

    Nevertheless a question remains: why did this happen?

  11. Neal_
    Posted 2 years ago #

    I just updated to 3.8 today, tried to solve a sidebar issue with Twitter Widget Pro not appearing, and now my website is crashed and I cannot login to correct it either.

    Glad to see it is not just me, and I hope this reassurance helps others in some way - but not being able to even login to try the above solution is crushingly disempowering.

    If anyone figures this out, I will be very grateful.

  12. Neal_
    Posted 2 years ago #

    I just got a great tip from WPRanger, who wrote,

    "You need to visit your site using FTP, download the functions.php file, correct the error and re-upload.
    You may have to activate PHP on your hosting account to do so."

    I did what he recommended and also found this website very useful for digging up the lost PHP file I needed, and hope it can help others too:


    I hope that's helpful, Neal

  13. becareerful
    Posted 2 years ago #

    I am getting an error 500 message and it is not allowing me to access the login screen. What do I do? Thanks!

  14. emellish
    Posted 2 years ago #

    To get the site back up and running without any errors, It was first restored to a previous backup and then had a line added to the wp-config.php "@ini_set('display_errors', 0);" to stop the error line from appearing at the top of the webpage.


  15. Andy
    Posted 2 years ago #

    Hi everyone,
    I have been reading similar threads for THREE straight days now, and I have found no resolution.
    Here's the breakdown of my (similar) situation:
    - Running latest (free version) MAMP on Mac OSX Mavericks

    - Using newest WordPress 3.8 download

    - I'll install the WP 3.8 onto my localhost no problem -- and sign in with no problem!

    - BUT, as soon as I shut down my computer and/or MAMP servers, and bring everything up and running again, I get the same old error on lines 749 - 753 of wp-login.php:

    "Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

    - I have repeated this three installations, it happens every time.

    I'm using Chrome and cookies are enabled.
    I clear the cache, clear the cookies, and the problem persists.

    Will wp.org address this please? It seems unresolved as far as local installations of WP-3.8 are concerned.

    - jh

  16. Neal_
    Posted 2 years ago #

    I got stuck like this earlier too and had to re-install the original php file through the server's access to my website, as opposed to using WordPress itself.

    Unfortunately, I'm not well trained here and am not sure if that will work in this case, but I hope that helps.

  17. Randy Hicks
    Posted 2 years ago #

    @jameshurst, the issue is most likely not wp3.8, but more likely the server setup concerning MAMP localhost. There are a lot of possibilities when dealing with a localhost considering we are all using our personal computer. That fact alone bring in unlimited possible side effects.

    Your cookies could be getting scrambled by a conflict between any of the following: php version, ports or document root. I'm not 100% on what kind of conflict, just spitballing here.

    <u>My setup</u>

    • Apache: 8888
    • MySql: 8889

    PHP v5.4.4
    Document Root: MAMP/Preferences/Apache

    As far as I know my setup is the default setup. When I downloaded and setup MAMP I changed nothing in the preferences. The only issues I've had have been related to file permissions and I don't think that is the case here.

  18. Meqs
    Posted 2 years ago #

    Is that not a strange root?
    Mine says:

    PHP v.5.5.3 (cache --)
    Doc Root: /Applications/MAMP/htdocs

    Or could that be the error?

  19. Randy Hicks
    Posted 2 years ago #

    Yeah, not sure what the heck that doc root was or why I wrote that, maybe it was late at night...

    Document Root: /Applications/MAMP/htdocs

  20. Meqs
    Posted 2 years ago #


    Still no solution :-(

  21. Randy Hicks
    Posted 2 years ago #

    I did find that one of my friends has some white space after the closing php tag in their functions.php. Also turn on WP_DEBUG from the wp-config.php on line 81 by setting it to true.

    // my code goes here
  22. Meqs
    Posted 2 years ago #

    I did not find any white spaces but did change false into true.
    Now I get the following massages trying to log on....
    (cookie errror remaines the same)

    Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /Applications/MAMP/htdocs/wordpress/wp-includes/wp-db.php on line 1142

    Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/wordpress/wp-includes/wp-db.php:1142) in /Applications/MAMP/htdocs/wordpress/wp-login.php on line 415

    Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/wordpress/wp-includes/wp-db.php:1142) in /Applications/MAMP/htdocs/wordpress/wp-login.php on line 427

  23. Randy Hicks
    Posted 2 years ago #

    It looks like there is a file somewhere that is triggering the headers.

    Try this to start:
    - temporarily de-activate your plugins or temporarily remove them (do not delete them, just move them to a temp folder)
    - revert your theme to to the 2014 theme

    This should put you back to start with your installation.

    - activate just the theme and see if that is your issue.
    - if your good start activating one plugin at a time.

    Alternate ideas
    - If you're running a theme that you've modified, try to install a clean version
    - if you've modified your theme look for white space

    Read the following post for more info on "header already sent"
    - http://stackoverflow.com/questions/8028957/how-to-fix-headers-already-sent-error-in-php
    - stackoverflow can be a good resource, especially when the stats are really high

  24. esmi
    Forum Moderator
    Posted 2 years ago #

    stackoverflow can be a good resource

    So can the WP codex.

    Try reviewing Solving "headers already sent" warnings

  25. Meqs
    Posted 2 years ago #


    Why or how come al the original wp-.php files don not end with a ' ?> '
    Is that not necessary?

  26. esmi
    Forum Moderator
    Posted 2 years ago #

    Not - a closing ?> is not necessary at the very end of a .php file. And it is often considered good practice to omit it in order to avoid these "headers already sent" messages.

Topic Closed

This topic has been closed to new replies.

About this Topic