Support » Plugin: All In One WP Security & Firewall » Can’t Log in or Out

  • Resolved nexusfred

    (@nexusfred)


    Hello,

    I enabled the Rename Login Page option and change the URL but when I try to use it I have get 404 page ? The classic URL …/WP-Admin result as a 403 page.

    When the plugin is activated I can’t log out ? I also get a 404 page. To do so I have to disable “All In One WP”

    This is a brand new WordPress install without any other plugin beside “All In One WP Security” with the default theme “Twenty Twenty”.

    WordPress Version 5.3.2
    All In One WP Security Version 4.4.3
    Cookie Based Brute Force Prevention: Disabled
    Filesystem Security = all in Green > “No Action Required”
    PHP 7.2
    ISPConfig 3.1.13 brand new install

    It’s may an issue with the ISPConfig settings, but if so, as I’m a new ISPConfig user of it I have no idea what I need to looking for.
    Unix it’s not my strong.

    Best Regards
    Nexus

    • This topic was modified 1 year, 6 months ago by nexusfred.
    • This topic was modified 1 year, 6 months ago by nexusfred.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    I enabled the Rename Login Page option and change the URL but when I try to use it I have get 404 page ? The classic URL …/WP-Admin result as a 403 page.

    When you enable this feature you need to log into your admin site via the yoursite.com/secretword URL. You can’t use yoursite.com/wp-admin.php or yoursite.com/wp-login.php any more. This is how this feature works.

    If you get a 404 page error when using this feature, then something in your site is blocking this. If that is the case, try the following. Disable all other plugins except ours, then try logging in via the yoursite.com/secretword URL again.

    Let me know if it makes sense to you.

    Thank you

    • This reply was modified 1 year, 6 months ago by mbrsolution.
    Thread Starter nexusfred

    (@nexusfred)

    Hi,

    I may do not explain it well, but It’s a brand new WordPress install without any other plugin than “All In One WP Security Version 4.4.3″

    WordPress Version 5.3.2 + theme “Twenty Twenty” + All In One WP Security Version 4.4.3 that all. So it’s can’t be an conflict with another plugin, there is no other else.

    I think that is an issue with my ISPConfig settings. But as I do not know what can block “All In One WP Security”, so I do not know what I need to check in my ISPConfig settings.

    Best Regards
    Nexus

    • This reply was modified 1 year, 6 months ago by nexusfred.
    Thread Starter nexusfred

    (@nexusfred)

    Solved !

    It’s an issue between nginx and WordPress/Apache.

    The “Rename Login Page Feature” works perfectly if the “Permalink Setting” is set to “Plain” but result as 404 if the “Permalink Setting” is set to “Post name”

    nginx does not understand the rewrite rules in the .htaccess.
    So the rules need to be translated for nginx.

    Solution : add this code on the nginx Directives

    location / {
    try_files $uri $uri/ /index.php?$args;
    }
    # Add trailing slash to */wp-admin requests.
    rewrite /wp-admin$ $scheme://$host$uri/ permanent;
    location ~* \.(jpg|jpeg|png|gif|css|js|ico)$ {
    expires max;
    log_not_found off;
    }

    Source :
    howtoforge.com isp config its working but phpmyadmin No
    howtoforge.com [SOLVED] WordPress permalinks are giving problems

    Best Regards
    Nexus

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Thank you Nexus for sharing your solution.

    Our plugin is designed for Apache servers. However you can still use it in Nginx and Windows servers. All you need to do is find the alternative code for any entries written to the .htaccess file by our plugin. These entries come from the Firewall tab features.

    I will also make a not of your solution for future reference.

    Kind regards

    • This reply was modified 1 year, 6 months ago by mbrsolution.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t Log in or Out’ is closed to new replies.