Support » Fixing WordPress » Can’t log in after 2.8 upgrade

Viewing 15 replies - 1 through 15 (of 30 total)
  • splorpuk

    (@splorpuk)

    [Update] I’ve put the files up again and I’m getting the following message after logging in as either admin:

    Parse error: syntax error, unexpected T_LNUMBER in /usr/www/users/splorp/shoot/wp-includes/class-phpass.php on line 50

    As I recall, phpass.php is something to do with the log on and passwords. Not helpful, but at least it’s progress of sorts.

    Ryan Paul

    (@othellobloke)

    I can’t log in either – just did the auto upgrade, tried getting a new password sent to me and that doesn’t work either.

    Someone help please?

    splorpuk

    (@splorpuk)

    @othellobloke – are you getting any errors messages, or just blank screen?

    compounder

    (@compounder)

    so im not the only one then. my site is down and it just has this error:

    Fatal error: Call to undefined method WordPress_Module::_weak_escape() in /home/frieders/public_html/wp-includes/wp-db.php on line 487

    also, cannot log in

    Ryan Paul

    (@othellobloke)

    My problem was the ‘limit-login-attempts’ plugin.

    I renamed the plugin install and created a new one via ftp and then I could login fine. So I enabled the plugins one one by one – I disabled that particular plugin and everything was cool.

    bh_WP_fan

    (@bh_wp_fan)

    Try renaming the plugins folder again then do a manual update to 2.8 again, making sure to upload all of the files. Also try increasing your memory_limit.
    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define(‘WP_MEMORY_LIMIT’, ’64MB’);)

    Carmen D

    (@carmen-d)

    I am having the same problem – cannot log in post 2.8 upgrade-when I try to log in I get this message:

    Fatal error: Call to undefined function: is_site_admin() in /home/.mollye/allaboutrace/allaboutrace.com/wp-content/plugins/sem-google-analytics-admin.php on line 20

    Any suggestions will be much appreciated. I am panicking. In advance, thank you

    bh_WP_fan

    (@bh_wp_fan)

    google analytics is broken in WordPress 2.8. Deactivate that plugin by renaming it in your wp-content/plugins directory. If that doesn’t fix it, rename the whole plugins directory.

    Carmen D

    (@carmen-d)

    Thanks bh. Renaming the directory worked. whew.

    simondelliott

    (@simondelliott)

    I have this problem, just upgraded to 2.8 i get WSOD on the site and the admin pages. I have also tried all the tricks, renaming plugins, altering the config file etc,,,
    the site is http://www.simondelliott.com/blog

    Any idea to try?

    jonahcoyote

    (@jonahcoyote)

    I noticed this same issue after updating a site running 2.7.1 to 2.8 I could not reach the admin at all unless I renamed the plugins folder. But, even after renaming it back it still didn’t work. So I renamed it, then re-copied the 2.8 files and added the ‘php_value memory_limit 64M’ to the .htaccess (the host supports it) and this seemed to solve the issue.

    I hope this helps. Maybe this will be fixed in 2.8.1?

    – Jonah

    toddklein

    (@toddklein)

    My problem is a little different but very annoying. I can log in to my admin page, but all the editing and posting links are gone! I just upgraded to 2.8, my site is on Lunarpages. Does anyone know a way to reinstall 2.7? At the moment I can’t do anything with my blog, though it’s still there. The only link that is still active is to Askimet spam, but that goes to “you do not have correct permissions to access this page”. I’ve tried getting help from Lunarpages, and they duplicated my problem, but say it’s not something they can do, I have to get help from WordPress. WordPress won’t help since my site is not with them. Argh!

    Mentions of renaming the plugins folder: what do you rename it to? I can try to find that on my site using FTP.

    Thanks for any help!

    simondelliott

    (@simondelliott)

    @jonahcoyote thanks for the help, Unfortunately it has not fixed the issue that Im finding, Ive tried the php_value memory limit and its giving me a 500 so I guess that my ISP does not support it.
    Im going to try recreating the whole thing from the distro and seeing if it works.

    simondelliott

    (@simondelliott)

    Ive just tried installing 2.8.1 and no joy,

    theorist

    (@theorist)

    To bh_WP_fan: Does one need to try all three of those options, or just one? I changed the memory in my config.php file, but it didn’t help. I get a white screen on my site and log-in page after upgrading.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Can’t log in after 2.8 upgrade’ is closed to new replies.