Support » Installing WordPress » Can’t load wordpress installation

  • Resolved arshiaaghaei

    (@arshiaaghaei)


    Hi
    I’ve installed LAMP on Arch-Linux
    Apache & MySQL servers are running
    php and php-apache packages are installed
    I’ve enabled the php module in apache config as well
    DB info has been written on wp-config.php
    But when I type localhost I just see a page that says:

    There has been a critical error on this website.

Viewing 4 replies - 1 through 4 (of 4 total)
  • threadi

    (@threadi)

    Take a look at the error log of your Apache. There you should see the reason for the error. If not, you could also enable debugging in WordPress as described here: https://wordpress.org/support/article/debugging-in-wordpress/

    Thread Starter arshiaaghaei

    (@arshiaaghaei)

    
    
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::694d:ef32:2b4d:48da%enp3s0f1. Set the 'ServerName' directive globally to suppress this message
    [Fri May 27 14:01:44.623852 2022] [mpm_event:notice] [pid 18474:tid 140208483871680] AH00489: Apache/2.4.53 (Unix) configured -- resuming normal operations
    [Fri May 27 14:01:44.623947 2022] [core:notice] [pid 18474:tid 140208483871680] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Fri May 27 14:01:50.451625 2022] [mpm_event:notice] [pid 18474:tid 140208483871680] AH00492: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::694d:ef32:2b4d:48da%enp3s0f1. Set the 'ServerName' directive globally to suppress this message
    [Fri May 27 14:01:50.499667 2022] [mpm_event:notice] [pid 18592:tid 140613036125120] AH00489: Apache/2.4.53 (Unix) configured -- resuming normal operations
    [Fri May 27 14:01:50.499783 2022] [core:notice] [pid 18592:tid 140613036125120] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Fri May 27 16:04:39.282813 2022] [mpm_event:notice] [pid 18592:tid 140613036125120] AH00492: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using ::1. Set the 'ServerName' directive globally to suppress this message
    [Fri May 27 22:52:04.136336 2022] [mpm_event:notice] [pid 554:tid 140673369476032] AH00489: Apache/2.4.53 (Unix) configured -- resuming normal operations
    [Fri May 27 22:52:04.136403 2022] [core:notice] [pid 554:tid 140673369476032] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Sat May 28 01:56:25.916828 2022] [mpm_event:notice] [pid 554:tid 140673369476032] AH00492: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using ::1. Set the 'ServerName' directive globally to suppress this message
    [Sat May 28 01:56:52.860046 2022] [mpm_event:notice] [pid 519:tid 139682842344384] AH00489: Apache/2.4.53 (Unix) configured -- resuming normal operations
    [Sat May 28 01:56:52.860113 2022] [core:notice] [pid 519:tid 139682842344384] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Sat May 28 03:19:57.006094 2022] [mpm_event:notice] [pid 519:tid 139682842344384] AH00492: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using ::1. Set the 'ServerName' directive globally to suppress this message
    [Sat May 28 15:42:02.513804 2022] [mpm_event:notice] [pid 490:tid 140329017076672] AH00489: Apache/2.4.53 (Unix) configured -- resuming normal operations
    [Sat May 28 15:42:02.513880 2022] [core:notice] [pid 490:tid 140329017076672] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Sat May 28 22:10:24.409661 2022] [mpm_event:notice] [pid 490:tid 140329017076672] AH00492: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::a8b6:2e10:f742:a2f9%wlp2s0. Set the 'ServerName' directive globally to suppress this message
    [Sat May 28 22:10:24.900717 2022] [mpm_event:notice] [pid 52020:tid 139657729981376] AH00489: Apache/2.4.53 (Unix) configured -- resuming normal operations
    [Sat May 28 22:10:24.900959 2022] [core:notice] [pid 52020:tid 139657729981376] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Sat May 28 22:14:44.655302 2022] [mpm_event:notice] [pid 52020:tid 139657729981376] AH00492: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::a8b6:2e10:f742:a2f9%wlp2s0. Set the 'ServerName' directive globally to suppress this message
    [Sat May 28 22:14:45.315924 2022] [mpm_prefork:notice] [pid 52690] AH00163: Apache/2.4.53 (Unix) PHP/8.1.6 configured -- resuming normal operations
    [Sat May 28 22:14:45.316017 2022] [core:notice] [pid 52690] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Sat May 28 22:14:49.036416 2022] [php:error] [pid 52694] [client ::1:47512] PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /srv/http/wp-includes/wp-db.php:1788\nStack trace:\n#0 /srv/http/wp-includes/wp-db.php(724): wpdb->db_connect()\n#1 /srv/http/wp-includes/load.php(561): wpdb->__construct()\n#2 /srv/http/wp-settings.php(124): require_wp_db()\n#3 /srv/http/wp-config.php(96): require_once('...')\n#4 /srv/http/wp-load.php(50): require_once('...')\n#5 /srv/http/wp-blog-header.php(13): require_once('...')\n#6 /srv/http/index.php(17): require('...')\n#7 {main}\n  thrown in /srv/http/wp-includes/wp-db.php on line 1788, referer: http://localhost/
    [Sat May 28 22:14:52.844406 2022] [php:error] [pid 52695] [client ::1:36744] PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /srv/http/wp-includes/wp-db.php:1788\nStack trace:\n#0 /srv/http/wp-includes/wp-db.php(724): wpdb->db_connect()\n#1 /srv/http/wp-includes/load.php(561): wpdb->__construct()\n#2 /srv/http/wp-settings.php(124): require_wp_db()\n#3 /srv/http/wp-config.php(96): require_once('...')\n#4 /srv/http/wp-load.php(50): require_once('...')\n#5 /srv/http/wp-blog-header.php(13): require_once('...')\n#6 /srv/http/index.php(17): require('...')\n#7 {main}\n  thrown in /srv/http/wp-includes/wp-db.php on line 1788
    [Sat May 28 22:15:15.722451 2022] [php:error] [pid 52696] [client ::1:38932] PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /srv/http/wp-includes/wp-db.php:1788\nStack trace:\n#0 /srv/http/wp-includes/wp-db.php(724): wpdb->db_connect()\n#1 /srv/http/wp-includes/load.php(561): wpdb->__construct()\n#2 /srv/http/wp-settings.php(124): require_wp_db()\n#3 /srv/http/wp-config.php(96): require_once('...')\n#4 /srv/http/wp-load.php(50): require_once('...')\n#5 /srv/http/wp-blog-header.php(13): require_once('...')\n#6 /srv/http/index.php(17): require('...')\n#7 {main}\n  thrown in /srv/http/wp-includes/wp-db.php on line 1788
    [Sat May 28 22:15:30.982742 2022] [mpm_prefork:notice] [pid 52690] AH00170: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using ::1. Set the 'ServerName' directive globally to suppress this message
    [Sat May 28 22:16:01.414685 2022] [mpm_prefork:notice] [pid 550] AH00163: Apache/2.4.53 (Unix) PHP/8.1.6 configured -- resuming normal operations
    [Sat May 28 22:16:01.414722 2022] [core:notice] [pid 550] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
    [Sat May 28 22:17:35.823369 2022] [php:error] [pid 738] [client ::1:52394] PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /srv/http/wp-includes/wp-db.php:1788\nStack trace:\n#0 /srv/http/wp-includes/wp-db.php(724): wpdb->db_connect()\n#1 /srv/http/wp-includes/load.php(561): wpdb->__construct()\n#2 /srv/http/wp-settings.php(124): require_wp_db()\n#3 /srv/http/wp-config.php(96): require_once('...')\n#4 /srv/http/wp-load.php(50): require_once('...')\n#5 /srv/http/wp-blog-header.php(13): require_once('...')\n#6 /srv/http/index.php(17): require('...')\n#7 {main}\n  thrown in /srv/http/wp-includes/wp-db.php on line 1788
    [Sat May 28 22:23:25.532129 2022] [php:error] [pid 741] [client ::1:43072] PHP Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /srv/http/wp-includes/wp-db.php:1788\nStack trace:\n#0 /srv/http/wp-includes/wp-db.php(724): wpdb->db_connect()\n#1 /srv/http/wp-includes/load.php(561): wpdb->__construct()\n#2 /srv/http/wp-settings.php(124): require_wp_db()\n#3 /srv/http/wp-config.php(96): require_once('...')\n#4 /srv/http/wp-load.php(50): require_once('...')\n#5 /srv/http/wp-blog-header.php(13): require_once('...')\n#6 /srv/http/index.php(17): require('...')\n#7 {main}\n  thrown in /srv/http/wp-includes/wp-db.php on line 1788
    [Sat May 28 23:15:36.933109 2022] [mpm_prefork:notice] [pid 550] AH00170: caught SIGWINCH, shutting down gracefully
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::a8b6:2e10:f742:a2f9%wlp2s0. Set the 'ServerName' directive globally to suppress this message
    [Sun May 29 00:35:17.594993 2022] [mpm_prefork:notice] [pid 41951] AH00163: Apache/2.4.53 (Unix) PHP/8.1.6 configured -- resuming normal operations
    [Sun May 29 00:35:17.595088 2022] [core:notice] [pid 41951] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'

    threadi

    (@threadi)

    You don’t seem to have installed or activated a PHP module for the database connection. You have to do that in your Linux distribution. Here should be a starting point for this: https://wiki.archlinux.org/title/PHP – otherwise you should rather turn to an Arch Linux community to solve this.

    Thread Starter arshiaaghaei

    (@arshiaaghaei)

    Yeah that was the issue, tyvm!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t load wordpress installation’ is closed to new replies.