Support » Plugin: WP Social Post And Widget » Can’t load login Page

  • Hey guys,

    i have some trouble with the plugin and can’t figure out whats the problem. Thats what wordpress says:

    An Error from Type E_ERROR happened in line 75 in file /var/www/html/wp-content/plugins/wp-instagram-post/vendor/mgp25/instagram-php/src/Settings/Storage/Components/PDOStorage.php . Error Message: Uncaught InstagramAPI\Exception\SettingsException: MySQL Connection Failed: could not find driver in /var/www/html/wp-content/plugins/wp-instagram-post/vendor/mgp25/instagram-php/src/Settings/Storage/Components/PDOStorage.php:75
    Stack trace:
    #0 /var/www/html/wp-content/plugins/wp-instagram-post/vendor/mgp25/instagram-php/src/Settings/StorageHandler.php(142): InstagramAPI\Settings\Storage\Components\PDOStorage->openLocation(Array)
    #1 /var/www/html/wp-content/plugins/wp-instagram-post/vendor/mgp25/instagram-php/src/Settings/Factory.php(200): InstagramAPI\Settings\StorageHandler->__construct(Object(InstagramAPI\Settings\Storage\MySQL), Array, Array)
    #2 /var/www/html/wp-content/plugins/wp-instagram-post/vendor/mgp25/instagram-php/src/Instagram.php(309): InstagramAPI\Settings\Factory::createHandler(Array, Array)
    #3 /var/www/html/wp-content/plugins/wp-instagram-post/classes/class-woo-igp.php(140): InstagramAPI\Instagram->__construct(false, true, Array)
    #4 /var/www/html/wp-content/plugins/wp-instagram-post/wpigp.log

    Some one have any idea how to fix it? The WordPress page have access to the Database any other plugin, too.

    Worpress Verison: 5.3.2
    Current Theme: Twenty Twenty (Version 1.1)
    Plugin Version: WP Social Post And Widget (Version 1.5)
    PHP-Version: 7.3.16

    phpinfo output (only the first few lines):

    PHP Version => 7.3.16

    System => Linux mydomain 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64
    Build Date => Mar 19 2020 23:32:48
    Configure Command => ‘./configure’ ‘–build=x86_64-linux-gnu’ ‘–with-config-file-path=/usr/local/etc/php’ ‘–with-config-file-scan-dir=/usr/local/etc/php/conf.d’ ‘–enable-option-checking=fatal’ ‘–with-mhash’ ‘–enable-ftp’ ‘–enable-mbstring’ ‘–enable-mysqlnd’ ‘–with-password-argon2’ ‘–with-sodium=shared’ ‘–with-pdo-sqlite=/usr’ ‘–with-sqlite3=/usr’ ‘–with-curl’ ‘–with-libedit’ ‘–with-openssl’ ‘–with-zlib’ ‘–with-libdir=lib/x86_64-linux-gnu’ ‘–with-apxs2’ ‘–disable-cgi’ ‘build_alias=x86_64-linux-gnu’
    Server API => Command Line Interface
    Virtual Directory Support => disabled
    Configuration File (php.ini) Path => /usr/local/etc/php
    Loaded Configuration File => (none)
    Scan this dir for additional .ini files => /usr/local/etc/php/conf.d
    Additional .ini files parsed => /usr/local/etc/php/conf.d/docker-php-ext-bcmath.ini,
    /usr/local/etc/php/conf.d/docker-php-ext-exif.ini,
    /usr/local/etc/php/conf.d/docker-php-ext-gd.ini,
    /usr/local/etc/php/conf.d/docker-php-ext-imagick.ini,
    /usr/local/etc/php/conf.d/docker-php-ext-mysqli.ini,
    /usr/local/etc/php/conf.d/docker-php-ext-opcache.ini,
    /usr/local/etc/php/conf.d/docker-php-ext-sodium.ini,
    /usr/local/etc/php/conf.d/docker-php-ext-zip.ini,
    /usr/local/etc/php/conf.d/error-logging.ini,
    /usr/local/etc/php/conf.d/opcache-recommended.ini

    <!– some lines not displayed for security reason –>

    Registered PHP Streams => https, ftps, compress.zlib, php, file, glob, data, http, ftp, phar, zip
    Registered Stream Socket Transports => tcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2
    Registered Stream Filters => zlib.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk

    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v3.3.16, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.16, Copyright (c) 1999-2018, by Zend Technologies

    Installed php plugins: bcmath, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, hash, iconv, imagick, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, PDO, Phar, posix, realine, Reflection, SimpleXML, sodium, SPL, sqlite3, standard, tokenizer, xml, smlreader, cmlwriter, Zend OPcache, zip, zlib

    Thanks for helping.

    Regards JJOSH

    • This topic was modified 8 months, 1 week ago by jjoshtech.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author qsheeraz

    (@qsheeraz)

    Hi,

    For some reasons, its not connecting to your database for login sessions.
    Please select connection method ‘File based’ instead of ‘Database’ from plugin options.

    Regards

    I have equal problem.
    When I click on login page I don view nothing, only empty page.
    Instead I view settings page.

    What is the problem??

    Thanks

    jjoshtech

    (@jjoshtech)

    @qsheeraz i don’t see the reason that its not connecting to the Database. Do you have any hint how i can figure our?

    Plugin Author qsheeraz

    (@qsheeraz)

    @hunterbit If login page is simply empty and no message then you might be missing any common php libs like exif, cURL, GD or mbstring. Can you please check your site log to see any info like this?

    @jjoshtech there maybe some settings difference or maybe you have maria db server. You can download v1.6 from the link given below. Not released yet. That’s why you have to manually download and install. Here you can select file based method instead of DB. Both are equal to work.
    https://downloads.wordpress.org/plugin/wp-instagram-post.1.6.zip

    Let us know about it.

    Regards

    jjoshtech

    (@jjoshtech)

    @qsheeraz ok i have MariaDB. Thats the reason. Why MariaDB doesn’t work?

    Thanks for the link already found it in anouther thread and installed it. File based the login Page is working. Now i have the “InstagramAPI\Response\LoginResponse: Challenge required.” problem …

    Plugin Author qsheeraz

    (@qsheeraz)

    @jjoshtech MariaDB a litter different in settings. This was actually designed for MySQL. But both methods are same. You can copy login sessions (just in case) as backup if you want. In DB method, you have to backup Database for sessions backup.

    Challenge required.” problem … Yes it may occur for old Instagram accounts or accounts having login history with a different location. Here is the detailed answer which may help you.

    Actually you are login from your web server through the plugin and your Web Server location maybe different from your routine Instagram login location. That’s why Instagram may show ‘Challenge require’ message to some users.

    Well this is Instagram security and it all depends on your login history. If you keep login from a specific location for most of the time and suddenly change your location with a new device, Instagram may trigger it as wrong login and may show this warning. Its same like you change your mobile device.

    To resolve this, you need to login to your Instagram account via the official website or your mobile device. You will see ‘unusual login attempt’ warning there.
    The area which is showing unusual login attempt is your Web Server location.
    You need to keep pressing ‘This was me’ until Instagram accepts your new login location. Nowadays its taking more time to proof new location due to tight security from Instagram. But sooner or later, Instagram will accept it. You may try with a break. Like a day or two and keep repeating it. But don’t try continuously. In some cases, keeping logout from your account from all devices for few days and then try to login through plugin will also be an effective way to connect.

    Or you can try by logout from every device, then use any vpn like browsec or hotspot shield and set location of your web server (The area which is showing unusual login attempt is your Web Server location.) Now login from official website of Instagram, logout and wait few hours. Then try login from plugin. That may work.

    But please note that these all are tricks and still its up to Instagram security if it satisfy or not.

    Another option is to use PROXY for your region to avoid any location change. Proxy option is available at plugin’s login page.

    Just for information, if you create a new Instagram account, it will have no location issue and you will connect immediately.
    Hope that will help.

    Regards

    Hi @qsheeraz

    You said: “For some reasons, its not connecting to your database for login sessions.
    Please select connection method ‘File based’ instead of ‘Database’ from plugin options.”

    Question: how to do this?

    UPD:
    So that the plugin could start, I had to do:
    — Factory.php.install 2020-05-09 13:37:05.000000000 +0300
    +++ Factory.php 2020-05-09 13:40:55.000417684 +0300
    @@ -41,6 +41,8 @@
    $storageConfig = [‘storage’ => $storage];
    }

    + $storage = ‘file’;
    + $storageConfig = [‘storage’ => $storage];
    // Determine the user’s final storage configuration.
    switch ($storageConfig[‘storage’]) {
    case ‘file’:

    During plugin installation:

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WP_Categories_to_Tags has a deprecated constructor in /var/www/html/wp-content/plugins/wpcat2tag-importer/wpcat2tag-importer.php on line 31 Warning: Cannot modify header information – headers already sent by (output started at /var/www/html/wp-content/plugins/wpcat2tag-importer/wpcat2tag-importer.php:31) in /var/www/html/wp-includes/functions.php on line 6221 Warning: Cannot modify header information – headers already sent by (output started at /var/www/html/wp-content/plugins/wpcat2tag-importer/wpcat2tag-importer.php:31) in /var/www/html/wp-admin/includes/misc.php on line 1259 Warning: Cannot modify header information – headers already sent by (output started at /var/www/html/wp-content/plugins/wpcat2tag-importer/wpcat2tag-importer.php:31) in /var/www/html/wp-includes/pluggable.php on line 1281 Warning: Cannot modify header information – headers already sent by (output started at /var/www/html/wp-content/plugins/wpcat2tag-importer/wpcat2tag-importer.php:31) in /var/www/html/wp-includes/pluggable.php on line 1284 Warning: Cannot modify header information – headers already sent by (output started at /var/www/html/wp-content/plugins/wpcat2tag-importer/wpcat2tag-importer.php:31) in /var/www/html/wp-includes/pluggable.php on line 1281 Warning: Cannot modify header information – headers already sent by (output started at /var/www/html/wp-content/plugins/wpcat2tag-importer/wpcat2tag-importer.php:31) in /var/www/html/wp-includes/pluggable.php on line 1284

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can’t load login Page’ is closed to new replies.