Support » Fixing WordPress » Can’t Leave Comments: Link Goes to Broken Single.php

  • Resolved shannon27


    View my blog at to see this problem in action!

    Problem: My Word Press site was working fine (see background info below), and now appears to suddenly be broken. When anyone attempts to leave a comment (by clicking on No/X number of Comments, they are taken to what appears to be the single.php page, BUT this page is showing more than just a single entry AND there is no place to leave a comment. Although the URL indicates it’s single, php, it looks very much like the main index page or an archive page. I don’t know what changed between yesterday and this morning, so I don’t know what to fix. Any advice would be greatly appreciated!

    Background: I installed Word Press for the first time a few days ago and everything has been working fine. I imported posts from another blog, added new posts from within Word Press, and made some pages to my theme’s headers, sidebars, and stylesheet. Last night I posted a new entry and everything seemed fine. Then I decided to change the timestamp on it to what should have still been a time in the past, but the post no longer appeared. Frustrated, I deleted that post and simply made a new post. Problem solved. At this point, I also added the widget to show a list of recent posts in the left sidebar. When my problem occurred, I commented out this recent posts widget, but this didn’t change my problem at all. I also read in the support forums to try updating my permalink structure. I did that, and nothing changed.

Viewing 1 replies (of 1 total)
  • For anyone else that finds this post: I solved the problem. I don’t know why, but pasting in the recent comments widget caused the problem. Commenting it out (but leaving it in the file) was not a solution. But completely deleting the widget did fix the problem.

Viewing 1 replies (of 1 total)
  • The topic ‘Can’t Leave Comments: Link Goes to Broken Single.php’ is closed to new replies.