WordPress.org

Support

Support » Plugins and Hacks » Can't install plugins, permissions problems etc.

Can't install plugins, permissions problems etc.

  • Hello,

    I just got my WP blog moved to new powerful server, then I tried to install any plugin it asked for FTP permissions I entered the details in config.php file (I googled it).. the problem got solved.

    But now when I try to install plugins, they give permission error such as, I received CHMOD 777 error while installing WP Total Cache. I think something messed up while changing webhost. I checked and matched the permissions from other WordPress blog they looked same. Then, why do I have to change them? Is there anything wrong with sever configurations?

    PS: I don’t wanna set permissions to 777 to every folder in root, it will cause security issues.

Viewing 1 replies (of 1 total)
  • Look at your permissions. Folders should be 775, files should be 644– http://codex.wordpress.org/Hardening_WordPress#File_Permissions.

    You will probably need to check the owner and group as well. Ideally, the owner should be your user and the group should be the group the server runs under. You will have to figure that out. I’ve seen ‘apache’, ‘www-data’, and others. Move slowly and carefully. It would be hard to destroy data but you could create a huge headache with a permission mistake.

Viewing 1 replies (of 1 total)
  • The topic ‘Can't install plugins, permissions problems etc.’ is closed to new replies.
Skip to toolbar