Support » Fixing WordPress » Can't install plugins

  • I can’t add plugins. I’ve checked files permissions and they are OK (775), disabled all plugins…
    current_user_can(‘install_plugins’) returns false when logged in as an administrator. any help?
    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Justin Greer

    (@justingreerbbi)

    Forum Moderator

    What is the error that you are getting when you attempt to download and add a plugin?

    Thread Starter desonhos

    (@desonhos)

    When visiting /wp-admin/plugin-install.php: ‘You do not have sufficient permissions to install plugins on this site.’
    On /wp-admin/plugins.php “add new” button is hidden.

    I tried with another admin user but same error occured

    [ No bumping please. ]

    Try updating wordpress, manually if necessary. It sounds like there is some corruption somewhere. If that doesn’t work, maybe try creating new admin user and try with that.

    was this resolved? We have just done a new install and while default site functions and can login w/ our initial (administrator role) account, we have no “Add new” buttons on the plugin or theme admin pages. Is there something we have missed in terms of file permissions, etc.

    resolved. our particular problem was pretty basic: modified wp-config.php changing this line from true to false:

    define(‘DISALLOW_FILE_MODS’,false);

    Hello,

    I’m having the same problem. How was this fixed? I’m not a web developer.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can't install plugins’ is closed to new replies.