Support » How-To and Troubleshooting » [Resolved] Can't install or upload any media.

[Resolved] Can't install or upload any media.

  • Every time I try to upload a theme, image, or basically anything on my self-hosted wordpress blog.. this pops up..

    Unable to create directory wp-content/uploads/2013/02. Is its parent directory writable by the server?

    And I haven’t figured out a way to fix it, please help if you can. Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Just create the file via ftp to get over the hurdle and set the permissions 755

    go to wp-content/uploads/2013/ and then create the folder 02

    Temporarily change the permissions on your /wp-content directory so it’s writable to WordPress, then upload something and let WordPress create the directories. Afterwards, be sure to change the permissions back on /wp-content

    Thanks, worked instantly.

    You’re welcome.

    I am having the same problem. Using FZ I changed the permissions on wp-content/uploads to 777 and tried to upload. No joy. Then added 2013 folder and set permissions to 777. Still no joy so added 02. Again, no joy. I uploaded a JPG file to 02 via FileZilla and WordPress does not see it in the library. What am I missing?

    Moderator Andrew Nevins


    Forum moderator

    Create your own thread for support with your own issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Can't install or upload any media.’ is closed to new replies.