Support » Plugin: Visitor Maps and Who's Online » Cant install Maxmind database

  • When I go to the Visitor Maps settings after installing the geolocation addon, I get the message “The Maxmind GeoLiteCity database is not yet installed. Install Now”. When I click on Install Now, it takes me to a new page that says “Sorry, you are not allowed to access this page.” This happens whether or not “Enable Geolocation” is checked.

    Also, the “Enable Geolocation” checkbox resets to empty every time I try to install the Maxmind database, and even if I check “Enable Geolocation” and update the settings, when I click on the visitor map viewer link in the Settings page, a popup opens up that says Geolocation is not enabled. Any suggestions? Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The Geo has been broken for several years. I have been fixing the plugin’s PHP code every time I upgrade the plugin to a newer version. Perhaps Mike will incorporate what I am pasting below.

    The issue is with the path to the GeoLiteCity.dat file. You can fix this by opening up the file: visitor-maps.php and then scroll down to about line 863

    Change the line to look like this:
    if ( !file_exists(WP_CONTENT_DIR .’/plugins/visitor-maps-geoip/GeoLiteCity.dat’) ) {

    You will notice that the /plugins part is missing, that must be added for you to be able to enable the geolocation.

    [ Signature moderated ]

    • This reply was modified 2 years, 6 months ago by Jan Dembowski. Reason: Removed signature

    I don’t have a file named that on my site. Any suggestions?

    Go to WP CONTENT – PLUGINS – VISITOR MAPS and Search Down you will find the visitor-maps.php file.

    RIGHT Click – Open It and Click on Switch to Code Editor. You will now see the Line Number on the Left. Scroll down to Line 863 and you are done.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cant install Maxmind database’ is closed to new replies.