WordPress.org

Support

Support » Plugins and Hacks » EWWW Image Optimizer » [Resolved] Can't install jpegtran

[Resolved] Can't install jpegtran

  • I can’t get jpegtran to work on my WordPress install. It says it is missing, but the jpegtran is already in the map. Giving all the permissions etc. doesn’t work. The server runs on CentOS 6.0, apache 2.2.23

    Plugin info:

    jpegtran: MISSING Install automatically | manually
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.68
    pngout: OK version: May 30 2012
    Graphics libraries (only used for conversion, not optimization): GD: OK   Imagemagick ‘convert’: MISSING
    safe mode: Off  exec(): OK  shell_exec(): OK  
    Only need one of these: finfo: OK  getimagesize(): OK  mime_content_type(): OK
    Debug Info

    jpegtran path:
    optipng path: /home/admin/domains/royaldevelopment.nl/public_html/Jaap_Boonstra/wp-content/ewww/optipng
    gifsicle path: /home/admin/domains/royaldevelopment.nl/public_html/Jaap_Boonstra/wp-content/ewww/gifsicle
    pngout path: /home/admin/domains/royaldevelopment.nl/public_html/Jaap_Boonstra/wp-content/ewww/pngout-static
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755
    user: admin
    Operating environment: Linux 2.6.32.47xls-domU #2 SMP Thu Nov 17 12:17:59 CET 2011 x86_64

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author nosilver4u

    @nosilver4u

    seem to be having lots of trouble on 64-bit servers. I’m going to compile 64-bit versions of the tools for the next release.

    Plugin Author nosilver4u

    @nosilver4u

    I’m still working on 1.4.0, and the binary will be included there, but if you want to get a jump-start on things, I’ve uploaded the new version of jpegtran here:
    http://www.shanebishop.net/uploads/jpegtran-linux64

    Put it in the wp-content/ewww/ folder, and name it jpegtran-custom and see if that works. If you use ftp to upload it, make sure you are in Binary mode, or it will likely not work at all.

    Plugin Author nosilver4u

    @nosilver4u

    released 1.4.0 with updated jpegtran, let me know if it works or doesn’t

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Can't install jpegtran’ is closed to new replies.
Skip to toolbar