Support » Installing WordPress » Can’t install

  • I’ve been trying to run install.php and it doesn’t work. I open the file using Explorer and get a response telling me it needs a wp-config.php file. I already created this file and entered my MYSQL info. I also have installed PHP. after that response is a bunch of coding… what else can I do?

Viewing 9 replies - 1 through 9 (of 9 total)
  • First step: please provide more information, so someone can help.

    Are you running this on your own server, or is it being hosted somewhere?

    If you’re running it on your own server, which websever are you using? Apache? Something else?

    Are you sure you’ve put all the WordPress files in the correct folders?

    If you’re seeing “a bunch of coding” it sounds like you might be seeing PHP code, which suggests that PHP might not be actually working.

    Give us some more information, and someone here should be able to get you working.

    Another option is to try a different browser if you’re still having problems.

    thanks for responding. I got a little further since my last post. I am hosting on my own server. This is running on Win2000 Server Adanced. I uploaded to the correct place and now I get the error message when trying to install: Your PHP installation appears to be missing the MySQL which is required for WordPress. MySQL server 4.1 is running and I installed PHP 5.0.4.

    Thank you

    This is not a WP issue this is an issue with PHP 5 does not have default support for MySql.

    Here are the instructions that worked for me:

    The required files from the PHP5 distribution package are… php-ini.dist, php5ts.dll, php_mysql.dll, php_mysqli.dll, libmysql.dll, php-cgi.exe

    You may read on the net the need to copy some of these DLLs to the <windows>\system32 directory and or the <Apache2>\bin directory. Neither of these are necessary as long as your php.ini is configured correctly, as it was in my original article.

    Secondly, when configuring PHP.ini there is one additional step required. Simply uncomment the (remove the first 😉 from the line


    As above, all other steps in the “Configuring PHP.ini” section should also be carried out with this single additional step.

    That’s all that is required, you will now have a working installing of PHP5 and MySQL.

    now when i try to run install.php i get this message: Your PHP installation appears to be missing the MySQL which is required for WordPress.PHP Warning: PHP Startup: Unable to load dynamic library ‘./php_mysql.dll’ – The specified procedure could not be found. in Unknown on line 0

    I tried uninstalling php 5 and installing php 4.4 but I still get the same results. Should I copy the php_mysql.dll file to any certain place?
    Thank you

    Moderator James Huff


    Halfelf Minion 🚀

    ok, now it seems i’m at the same point many other members are at. “Error establishing a database connection”. all the other posts and links to other posts and stuff aren’t doing me any good. I know I have the database settings correct and I know MySql is running I can see it running when I open MySQL Administation. I’m hosting my own site so I don’t have cPanel or any idea how to configure phpMyAdmin which seems to have no user interface upon installation. I’ve downloaded so many programs to try to manage MySQL database and still can’t find one to use to add a user, database and set passwords. the MySQL command line doesn’t tell me how to do this. Any help? Thank you

    I tried one more thing and this didn’t help either: I found a suggestion to run this: <html>
    $link = mysql_connect(‘mysql_host’, ‘mysql_user’, ‘mysql_password’)
    or die(‘Could not connect: ‘ . mysql_error());
    this is the result I get after putting in my localhost, usernamd and password:

    Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in c:\program files\icode\everest\ecommerce\shop administrator\psilyu\blog\wp-admin\test.php on line 8
    Could not connect: Client does not support authentication protocol requested by server; consider upgrading MySQL client

    I hope this makes sense to someone.

    Moderator James Huff


    Halfelf Minion 🚀

    Please be sure that you are not using MySQL v4.1.7. v4.1.7 contained a bug with the authentication protocol, it was fixed in v4.1.8.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t install’ is closed to new replies.