Support » Installing WordPress » Can’t install

  • Hi guys, cant seem to make wordpress to work on my server.
    my config file is as such
    <?php
    /** WordPress’s config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘blog’); // The name of the database
    define(‘DB_USER’, ‘jerz777’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘123456’); // …and password
    define(‘DB_HOST’, ‘supremeserver15.com’); // 99% chance you won’t need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define(‘ABSPATH’, dirname(__FILE__).’/’);
    // Get everything else
    require_once(ABSPATH.’wp-settings.php’);
    ?>
    when I open wp-admin/install.php its says:
    Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.
    Are you sure you have the correct user/password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    but my information is correct or at least I think so…..
    thankz guys for helping out…..
    MySQL version : 4.0.20
    PHP version : 4.3.4
    Mysql host : supremeserver15.com

Viewing 2 replies - 1 through 2 (of 2 total)
  • 1. Are you sure that you needed to change DB_HOST to supremeserver15.com? Most people can get away with leaving it at localhost.
    2. A lot of hosts will prepend your database name & database user with your account name. If you have phpMyAdmin available; have you used it to confirm the names of your database & database user?

    Does your mysql host require a mysql. prefix when you access it via www, like with phpmyadmin? For example, mine is on my server, so technically the host is hauntedpalace.net. But the config file requires “mysql2.hauntedpalace.net” in order to connect.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can’t install’ is closed to new replies.