Support » Fixing WordPress » Can’t insert picture in post with 2.5

  • I have been trying to insert an uploaded picture into a post since I (locally) installed 2.5 RC1. (Now upgraded to 2.5)
    I have no problems uploading my pictures, but then it seems to go wrong.
    I hit the add Media -> add a picture-button, then I choose the ‘Media library’ where I choose the picture I want.
    Title, caption and description are already entered, I chose to have no link, choose the alignment and size I want, hit ‘insert to post’, and then the middle of the ‘greybox’ turns white, and nothing else happen. When I close the graybox, by hitting on ‘x’, (which is the only thing I can do), nothing has changed to my post…

    Maybe (as a non-english-speaking user) there is something I misunderstood, but when that’s so, it should be made a little bit easier.

Viewing 15 replies - 1 through 15 (of 86 total)
  • Presently I can upload pictures fine with IE7 but not with Firefox. I did an upload with IE7 and it shows up under “Gallery”. The same thing is happening to me here when I try to insert the box just blanks and nothing happens.

    I am having the same issue. I can add my already existing gallery images just fine, but if I try to upload an image, the little box on the screen just freezes. Nothing ever uploads.

    I am using Firefox on a *nix box. Are there any fixes? Is it a Firefox issue?

    I cannot even add my existing images, same problem, the box just goes blank.

    I don’t even get the add media right now in a new post page =/

    having similar image upload problems:
    http://wordpress.org/support/topic/164293?replies=7

    When I try to upload an image using the Add Media: Add Image button, The dialog shows up just fine and I can browse for images under the Choose File tab.
    Clicking the Upload button results in he image being listed underneath but without an image showing. Clicking on the “Show” link beside it also does nothing.
    Going through the “Gallery” and “Media Library” has the same result with no images showing but their titles visibleand the “Show” link not doing anything.

    What is this dialog supposed to look like and behave?

    I think this issue is getting confused, the original poster and I could upload fine, but when trying to insert a thumbnail or otherwise into the story the window simply blanks.

    No fix is known for that so far as I know.

    I had this problem too! Then I cleared my browser cache, deactivated all my plugins, and re-installed the upgrade.

    After that I was able to insert the html code into the post box.

    (Note: the code shows up, and the image appears correctly when you publish the post, but I could not view the image in the editor, only on the actual page after publishing.)

    Hope this helps somewhat…
    And especially hope that there’s a real/better fix soon…

    Browser cache isn’t working for me, I wish I had kept a backup of my DB prior to the upgrade as I would very much like to revert back to 2.3.3 for the time being.

    @kristanlh and canadianpj: thank you for adding something to the discussion I hoped to start.
    I will try to re-install, like kristanlh suggested, but I wonder if this will solve the problem: it already existed when I installed RC1, and it still is there after having installed the definitive 2.5, so I already de-activated my plugins, en re-installed.
    But I didn’t clear my browser cache.
    And I didn’t try another browser, but I could try, since I have my local install on a Windows machine (for some reason, WordPress locally installed on my Linux-pc is very, very slow, but that’s another problem…)

    I’m wondering if this problem could be linked to an install on a Windows-configuration instead of a linux-server? I still have to test all my plugins, and when they do work, I think I’m going to install 2.5 on the ‘real’ server where my site is on, hoping that I don’t have this problem there.

    @ kristanpj: After (only) clearing my browsercache my problem was solved.

    I did a re-clear and it works now, weird that it did not the first time so my only remaining problem is I cannot upload with Firefox, only IE.

    Actually this problem has returned for me…

    Same 🙁 It worked, re-cleared, did not work and still will not no matter how many times I clear it heh. Hoping for 2.5.1 soon and I’m sure there hard at work on fixes.

    In my situation, it uploads ( can see the images through ftp) but nothing in the image gallery and it stops with crunching……however I can HAND code the image into my post using the URL..so that is a work around for now. However, I agree…this is pretty unnerving when you have an active blog.

Viewing 15 replies - 1 through 15 (of 86 total)
  • The topic ‘Can’t insert picture in post with 2.5’ is closed to new replies.