Support » Fixing WordPress » cant insert links with visual editor

  • Something went wrong today…the visual editor worked great yesterday…now it wont allow me to insert links…pops up a blank box with javascript errors:

    Line: 2
    Char: 1
    Error: ‘tinyMCEPopup’ is undefined
    Code: 0

    I run an xp system with kaspersky anti virus…everything was great yesterday

    I went into all the IE setup and put the site in trusted and gave all scripts permissions to run..

    I can insert links with HTML editor…but not visual..have cleared cache and all help

    Any ideas

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi


    Forum Moderator

    Try re-uploading the wp-includes folder.

    I loaded thi site on a hostgator hosting platform using the built-in fantastico…so I have no copies of that file to re-upload

    A. where can i get that fil

    B. will the 2.9 upgrade fix the problem?


    OK…I went to WP and downloaded a copy of 2.8.6 to my desktop…extracted the wp-includes file…uploaded it to the site…and made sure to copy it into the correct site.

    Still no changes…when I try to insert a link into a post the visual editor pops up a java script box…which is what is supposed to happen..but no contents..just blank…

    Any suggestions?



    Forum Moderator

    Have you tried using another browser? Or another machine?

    Khaled Hakim


    As of now I am facing the same problem:

    When trying to edit a post from within the admin control panel… anything that triggers the loading of a lightbox results in the lightbox being loaded with blank contents (nothing to see). You can find your way to the “X” that is invisible on the right hand corner of this empty light box and resume editing, no problem… but where is the lightbox’s contents?

    So I’m facing the same issue. It’s not a browser issue. I’ve tested this on Google Chrome, Firefox, and IE… they all have the same problem.

    The error I in explorer when I click on, say, “insert hyperlink” from the “edit post” in wordpress is:
    Error:’tineMCEPopup’ is undefined

    I’m not browsing for a solution.. Will post it here if I come across one. If anyone has a solution, please post it as well.

    Khaled Hakim


    This is, in specific, a way I have found to solve a problem for the following error: ‘tinyMCEPopup is undefined’

    But it may also be a successful solution for other problems faced with WYISWYG admin side editor.

    So, if you are finding yourself facing problems with your WordPress Admin-side WYISWYG editor, where say for instance when you click on a the “add link” button in the editor after highlighting text, the lightbox window loads with empty content, or the same empty lightbox appears when you try to change the color of text by clicking on the color picker and selecting more colors… then this is a viable solution for you.

    Download the following plug-in:

    If you prefer to install plug-ins directly from within WordPress, then search for the Plug in named: TinyMCE Advanced | Version 3.2.7 | By Andrew Ozz

    > After installation is complete, Activate the plugin.
    > Go to the dashboard of your admin
    > On the left hand side, find the TinyMCE Advanced listed under “Settings” and Open it up.
    > You will see your existing WYSIWYG editor followed by two empty gray rows. Below these two empty rows is another container with a whole lof of new buttons you can add to your WYSISWG editor by clicking and dragging.
    > Add buttons by clicking and dragging from the bottom to the two empty gray rows. Even if you do not need to add buttons, add some for the heck of it, and to make sure that plug-in is activated / enforced to come into action – if that is the right phrasing.
    > Save settings.
    > Go to edit a post or a page. Highlight some text and try inserting link by clicking on the link icon in the WYSIWYG editor. Or try doing something that was “not working” before, such as editing color of text.

    > It should work now.

    Please let me know if this solution worked for you.



    I’m having this exact same problem. I think this must be the TinyMCE Advanced plugin problem. Looks like the solution is to upgrade your TinyMCE plugin.

    Thanks for the tip Khaledhakim, that helped me out.

    Hi, I am having a similar problem with some (internal) links and the visual vs. html editor.
    I have pasted some HTML code into the html editor. I update the page and all is well. I go back to the editor, and switch to the visual editor – even if I don’t make any changes to the content – then go back to the HTML editor, and some of the html code is missing, namely:

    <h5><a name="deals" class="insideLink">Deals:</a></h5>

    turns into this:

    <h5><a name="deals"></a></h5>

    So, the class="internalLink" has been removed, and the content between the tags is gone! It also seems to remove any <p> paragraph tags elsewhere in the content… which is fine, as it still seems to work ok.

    Has anyone else come across this issue?? Any help appreciated…

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘cant insert links with visual editor’ is closed to new replies.