Support » Fixing WordPress » Can't insert images in WordPress 3.5.

  • Ever since I’ve updated to 3.5. I’m unable to insert images into posts. I can upload them or select them from the media library, but when I click ‘insert into post’, nothing happens.

    I’ve read on another thread that I should add some code to the wp-cofig.php, but I don’t have this file…

    Another solution perhaps?


Viewing 15 replies - 1 through 15 (of 21 total)
  • Hi Wonderful Wanderings,

    I am facing the same issue.I have never faced so much issues with any of the previous wordpress versions.

    @rahul, per the forum guidelines, if you need help, please post your own thread. It’s much easier for forum volunteers to only help one person per thread. And in your thread, please include the information that’s suggested in the post linked to above.

    @wpyogi, thank you for the link. I hadn’t found that one yet.
    I’ve first cleared my browser cache and turned off my cache plugin.
    That didn’t work.
    Than I turned off all of my plugins and saw that the problem had gone.
    The weird thing is that when I put all of my plugins back on, it still worked.
    So for the moment I can insert images into posts, but I don’t know what the problem was.
    Another problem has occurred, though, but I’ll open another thread for that.

    Yeah, plug-ins are like that sometimes — they just get in a bad mood and turning them off and on somehow fixes them (too bad we can’t do that with some people, huh?)!

    I take it back.
    It just stopped working again:/
    Not able to insert an image into a post:(

    Rats, switch them off again and change to the twentyeleven theme…then add them back one by one.

    BTW, what theme are you using?

    Switch my theme?
    How do I do that without losing everything?

    I’m using Weaver II

    This is my site:

    Addition: because I was working on existing posts, I’m trying to insert images everywhere and now all of a sudden I found a post/picture it worked with. Very strange

    You won’t lose anything by temporarily switching themes, but have you checked on the Weaver site to make sure you’re up-to-date with it? Looks like there are some recent updates.

    I’ve got the latest version of my theme, so that shouldn’t be the problem.
    I’ve also posed the question on the Weaver II forum, but no answer so far.

    I’ll look up how I have to switch theme’s (although it sounds scary).

    But I’m wondering: I changing themes doesn’t change anything to the site: then why are they different themes?
    (You have to know, I’m very noob to all of this:D)

    This will help with that:

    Just looked at your site — looks like you are using the CKEditor? Maybe try switching to the regular default one and see if that helps.

    Yes, I am.
    I’ve already thought about changing editor because I’m also having trouble with captions (I’e opened another thread for that), but I like this one so much:/
    Will try turning it off now.

    I’ll try the theme switch tomorrow, with a fresh head

    Update: seems as if the CK Editor was the ‘bad one’.
    I turned it off and then tried to
    – insert an image in a post I couldn’t insert an image into before
    – added captions where I couldn’t before (related to other thread/problem)

    Both worked.

    Seems like I’ll have to start looking for another editor plugin.
    Going to get some sleep now.
    I’ll continue working on it tomorrow and I’ll keep you up to date. If all still goes fine when leaving the plugin of tomorrow, this is solved

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Can't insert images in WordPress 3.5.’ is closed to new replies.