Support » Fixing WordPress » Can't Insert Image – Tells me to please try again

  • Resolved bethanykenyon


    I can’t insert an image into my post. Here’s what happens: I have the text of my post all typed out. I click on the insert image icon from the insert toolbar above my post. A dialogue box appears with the title, “Add an image,” then inside it says, “Are you sure you want to do this?” and underneath that statement is a link that reads, “Please try again.” I click the “Please try again” and inside the same dialogue box, with the “Add an image” title, my Edit Post page appears, complete with the sidebar and toolbar and all the text I had just typed. It’s really weird.

    I have tried editing the post on different browsers and on different computers and the same thing always happens. It has never happened before tonight. One note, when this first happened this evening I noticed that I had a message that there was a Word Press update. I thought maybe this was because my version of Word Press was out of date. So I updated and am now running 3.1.2 and the problem persists.

    My blog is at

    Thanks for any help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Thanks. I deactivated my plug-ins and the culprit seemed to be a Google Analytics plugin. Not sure what the conflict was. It was a new plugin though. If I figure out what the problem was I’ll post it here.

    Appreciate the help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't Insert Image – Tells me to please try again’ is closed to new replies.