WordPress.org

Forums

ImageMapper
[resolved] Can't insert image map into post (9 posts)

  1. tmconnect
    Member
    Posted 2 years ago #

    This looks to get a great plugin.

    There is only one bit at least important problem for me: I can't insert an image map into a post in WP 3.5 (earlier versions not tested). If I open the new image uploader and change to the ImageMaps section I see my image map. After clicking the entry the uploader is closing and nothing is inserted into the post.

    Any idea what's going wrong. Thanks.

    http://wordpress.org/extend/plugins/imagemapper/

  2. Spike
    Member
    Plugin Author

    Posted 2 years ago #

    Hi and sorry for late answer.

    For some reason that bug happens with the new Media uploader in WP 3.5. I've fixed the problem and will update it today as soon as possible.

  3. tmconnect
    Member
    Posted 2 years ago #

    Sorry, but with the new version 0.3 I get the same problem that there is noting inserted into the post editor.

  4. Spike
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for reporting the problem.

    Hmm. For some reason I'm not able to reproduce the problem which makes diagnosing hard. Can you tell which browser and browser version are you using? Also are you using some plugins which might affect to the editor or media uploader functionality?

    The code does not actually add an image to the text, only a small tag like this: [imagemap id="{ID}"]. (The reason for this is that the code for an image map can be huge and editing the post code would be a way harder.)

  5. tmconnect
    Member
    Posted 2 years ago #

    I do not know why, but now everything works.

    I deactivated all plugins and reactivated each one by one to determine which of them is causing the problem. After activating all plugins inserting the shortcode through the media uploader is no problem.

    Sorry - please excuse the mess.

  6. Spike
    Member
    Plugin Author

    Posted 2 years ago #

    No problem. Glad you got it working.

  7. neuroticartist
    Member
    Posted 2 years ago #

    I was having the same problem, updating the new patch seemed to work but now I am having the image map turn black when I mouse over it. How can I make this transparent?

    its posted in a temp post here:
    http://soundchecknashville.com/welcome/

    Great plugin btw, I searched for days for something like this!

  8. reluctantexan
    Member
    Posted 1 year ago #

    I know this is resolved, but I'm drowning here.
    I want to use my imagemap as the header on all my wp pages. How can I do that, or can I?

  9. Spike
    Member
    Plugin Author

    Posted 1 year ago #

    Hey,

    You need to add this code to the header template file of the theme you're using:

    <?php echo get_imgmap_frontend_image('86', '79467984'); ?>

    86 is the ID of the image map and 79467984 is just a random ID for the HTML element.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • ImageMapper
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.