Support » Fixing WordPress » Can’t insert an image in post or page

  • All of a sudden I can’t insert an image in my WordPress blog. I can see the HTML of the image on the page but when I upload it all it shows is the title of the image. The image address is ok as it works other places. What am I doing wrong now. I watched videos on how to do it & followed them exactly, but still nothing works. Help!
    donrock

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    esmi,

    Tried all the things you suggested none have worked. I have a number of blogs with the same domain & some of them work. Any other ideas?

    donrock

    esmi

    (@esmi)

    Forum Moderator

    Check that the uploads folder is correctly entered as wp-content/uploads (no trailing slash) in Admin/Settings/Miscellaneous.

    esmi,

    Here’s the upload folder. Does this look alright
    Store uploads in this folder /home/donrock/public_html/donrock/realestate/wp-content/uploads Default is wp-content/uploads
    Anything else I can look at?

    donrock

    esmi

    (@esmi)

    Forum Moderator

    Does this look alright

    Try just using /wp-content/uploads

    esmi,

    I’ll try that. I’ve given up on the blog I was working on & started a new one. The images load great in it but I can’t make the You tube videos appear on the post. I tried several different video tutorials but still only get a link which does go to the video on you tube. Any idea why that happens. Its a new blog so there shouldn’t be too many problems with it. I’ve only got Kismet & easy adsense plugins on at present.

    donrock

    Nile Flores

    (@blondishnet)

    Yoast Support

    Did you use the embed code Youtube provides? That should work.

    esmi & blondishnet,

    Thank you both for the help. I finally got it to work. I must not have been holding my mouth right yesterday because earlier today I tried it & it worked just like it was supposed to.

    donrock

    Vassist

    (@vassist)

    I am having a problem with inserting an image into a post. When you click on the “insert image” button – a new window opens and it says “are you sure you want to do this – please try again”.

    I have also tried from the “quick edit” – same problem.

    When you click on the “try again” – all it does is insert a copy of the post you are working on, into the new window.

    I have tried to deactivate and reactivate the plugins – still no joy.

    Can anyone help?

    I upgraded to WordPress 3.0.1 and now I can’t insert images! Basically if I try to upload an image I get directed to the upload page but the upload page now takes up the full screen (I think it used to be a popup?) I can go through the upload process but can no longer insert images into posts as when I press insert into post I just get a blank screen and the only way I can get back to the insert post is with the back browser button, but there’s no sign of the uploaded image.

    Secondly on images that are already in the posts, I can no longer edit the image with the little button that pops up when you click on the image. The screen just goes dark and absolutely nothing else happens. This is a big issue that didn’t used to happen. Help!

    I’m having a similar problem. I can edit pictures that are already on my site but I can’t add any new ones. After I upgraded to 3.0.1 I am no longer able to insert images into posts or pages from my library. I *can* insert images “From URL” but not “Media Library”. Everything worked fine prior to upgrading.

    I checked the uploads folder (images are where they need to be), I set my theme to the default and I disabled all of my plugins and it still will not insert images from my gallery. I even tried using various browsers such as FireFox, IE, and Chrome. Please help! Also, I have never edited any code or tweaked anything..I’m just an end user of WP.

    I get this error:

    Error 404: File Not Found
    The requested page is not found. This may happen due to the following reasons:

    Page or file is outdated, renamed, moved, or does not exist.
    You typed the address incorrectly, like http://www.example.com/pgae.html instead of http://www.example.com/page.html
    Please contact your webmaster if you are not sure what goes wrong.

    Hi, How do I add a new support issue? and I am getting this error:

    When you click on the “insert image” button – a new window opens and it says “are you sure you want to do this – please try again”.

    How do I fix this?
    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Can’t insert an image in post or page’ is closed to new replies.