cant insert a pdf, cant run wordpress update, cant install a plugin - pls help! (2 posts)

  1. leisadent
    Posted 3 years ago #

    Hi all, it started when I tried to insert a pdf - the uploaded file could not be moved to /home/smalexan/public_html/wp-content/uploads - then tried to run the wordpress update - unpacking the update… could not create directory.: /home/username/public_html/wp-content/upgrade/wordpress-3.tmp - and couldn't even install a plugin. After scouring the wp help pages, I contacted my host who told me to try the wp help pages.

  2. The problems you are experiencing are due to WordPress not being able to write to the file system. This is either due to wrong file permissions or user / group ownership settings of the files.

    There is not a one size fits all solution since there are so many different server hosting configurations. See http://codex.wordpress.org/Changing_File_Permissions.

    You can try and go back to your host and tell them that the user PHP is running under needs to be able to write to the file system and create directories. Your host should be able to tell you what settings are needed to accomplish this.

Topic Closed

This topic has been closed to new replies.

About this Topic