WordPress.org

Support

Support » How-To and Troubleshooting » Can’t import WordPress WXR files

Can’t import WordPress WXR files

  • I’m trying to move my WordPress blog from one server to another. I’ve set up the WordPress installation on the new server, and exported a WXR file from my original server. However, when I tell the new server to import the file, using the Tools->Import tool, I don’t get any error messages, but it never imports anything.

    It gets past the screen where I can map existing users, but when I click to start the process, the page acts like it’s doing something, but then just loads a blank import page and doesn’t actually do anything. I’ve tried with several different WXR files, ranging from around 450k to a little under 2MB. These files represent different date ranges on my original blog.

    Does anyone know what might be happening, or how I can get the import to work? I’ve done several imports in the past and all of them worked fine, so I can’t figure out why I can’t get this one working.

    Thanks in advance for any help!

Viewing 15 replies - 1 through 15 (of 24 total)
  • I have the exact same issue.

    It seems like there’s a lot of importing issues in the newest build.
    I can’t import either

    After messing with it for a while I have some more information. It seems to just stop execution after a similar (but not the same) amount of progress on each attempt

    To isolate the problem I tried making a smaller import xml file. I’m importing a ton of tags so I removed all of the post <items> and just left the categories/tags in.

    The tags are in alphabetical order in the xml file and after the import stopped I checked my Post Tags to see how far it made it. I refreshed the database and tried again and checked again, and it stopped on the same letter of the alphabet but made it slightly further (by 4 or 5 tags). Each time it will run for about 10 seconds before I get the blank Import screen and progress is halted.

    This suggests that it’s some timeout issue with execution on the server. I tried changing the following php.ini values

    post_max_size = 64M
    upload_max_filesize = 64M
    max_execution_time = 600
    memory_limit = 64M

    The changes are reporting to have taken effect but there’s no difference in the import. Are there any other values that I should be increasing or do you have any other ideas as to why this might be happening?

    I just downgraded to 2.9 and it still isn’t working

    yah I tried it on 2.8.5 and same result

    RangerPretzel
    Member

    @rangerpretzel

    My friend has a popular WordPress blog on WordPress’s site and she’s trying to move her site over to hosting on another hosting provider with her own domain name, etc.

    We’ve got the WordPress PHP software installed and even altered the php.ini file so that it raises the upload limit to 64MB (per mdisanto’s recommendation.) And I’ve verified that when we do the WXR import, the WXR/XML file actually ends up in the “uploads” directory, but once it finishes uploading, nothing happens. We never reach the “users” screen.

    Any updates on this issue?

    RangerPretzel
    Member

    @rangerpretzel

    Btw, she’s uploading a 31MB file.

    RangerPretzel
    Member

    @rangerpretzel

    Ok, so I created a shortened version (750KB) of the WXR file and it uploads quickly and gives me the “users” screen where I assign the entries to the admin and then click “submit”. It does its thing for a few seconds and says “done”.

    But when I check the Posts? Still nothing.

    Shane G.
    Member

    @shane-g-1

    Hi,

    Check with these options:

    * Break the WordPress WXR file into smaller pieces by separating the data between a posts and pasting the header into each file.
    * Increase the PHP memory limit in php.ini by changing the memory_limit setting (e.g. memory_limit = 64M 😉
    * Increase the PHP memory limit via .htaccess (e.g. php_value memory_limit 64M)..
    * Increase the PHP memory limit via wp-config.php (e.g. efine(‘WP_MEMORY_LIMIT’, ‘64MB’);)

    More Details….

    Thanks,

    Shane G.

    RangerPretzel
    Member

    @rangerpretzel

    Hi Shane,
    I already tried breaking the WXR file into smaller ones (as listed above.) It imported the Tags and Categories, but none of the posts.

    php.ini is already modified per mdisanto’s recommendation.

    .htaccess does not work for me as the host provider does not run PHP as a module.

    I’ll try hacking the wp-config.php file, although the php.ini file should already take care of this…

    Thanks.

    RangerPretzel
    Member

    @rangerpretzel

    Anyone? Surely, I’m not the only one trying to export from the WordPress website and import into my own host provider running the WordPress software running into this problem. Right?

    RangerPretzel
    Member

    @rangerpretzel

    Ok guys. I wanted to thank everyone for their support…

    And also, I’ve come up with a solution of my own. I wrote my own WXR file splitter. It requires a Windows PC and the .NET 2.0 framework (which I think pretty much everyone has installed by now…)

    My file splitter takes any size WXR file (I tested with a 32MB file) and loads it into memory, and then splits it up into many smaller files which are perfect for uploading in small batches.

    You can download it for free from my website: Split WordPress XML RSS (WXR) files

    Cheers!

    struggling with the same problem, my original xml export is 11MB which wordpress chokes on, i used the splitter linked above which works fine, the problem is that there is a lot of data and a lot of attachments and wordpress seems to timeout if each xml file has more than 30 items, although sometimes it just completely doesn’t work. basically it looks like i will need to import 200 individual xml files? uhhhh i hope not 🙁 i’ve tried changing .htaccess, php.ini, defining wordpress memory in wp-config, commenting out wordpress timeout in wp-admin/import/wordpress.php and haven’t had any luck. i’m on godaddy and have asked for support but aren’t getting any help on this.

    i had to split the xml into 46 smaller xml files, when the import screen times out and stops loading just hit reload and send data and it will continue on, took several hours but it worked

    however, i notice that posts no longer have tags, is this a bug in the import? any solutions to this?

    as someone mentioned elsewhere a good idea is to perform the import on a local install, then export to sql from there

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Can’t import WordPress WXR files’ is closed to new replies.