WordPress.org

Support

Support » How-To and Troubleshooting » Can’t import remote files with WordPress’ Import function

Can’t import remote files with WordPress’ Import function

  • Hi.

    I was trying to import a WordPress XML file in my self-hosted blog. The XML file was exported from my blog hosted by wordpress.com

    When I try to import it, I select that I want to import the remote files too. But there’s a problem with that and in every post it says an error like “Remote file is incorrect size”.

    I read here that it is a bug, but the solution they propose is not working for me.

    Any suggestions?
    Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • No idea? 🙁

    same for me… is the tech team of wordpress.com or wordpress.org not able to repair this bug ?

    I’ve got the same problem. Need a solution 🙁

    In my case another issue cause the error message in my 2.8.4 installation. I solved it by inserting
    $headers['content-length'] = $headers['content-length'][1]
    right after
    $headers = wp_get_http($url, $upload['file']);
    (line 619) in wp-admin/import/wordpress.php.

    More detailed information can be found on my blog.

    This is what worked for me for the “Remote file is incorrect size” problem.

    PHP safe mode needs to be set to off.

    kay102’s solution worked for me. I didn’t have to change anything to do with PHP or the webserver.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t import remote files with WordPress’ Import function’ is closed to new replies.