Support » Plugin: WP RSS Aggregator » Can't import feed from a w3c valid xml

Viewing 4 replies - 1 through 4 (of 4 total)
  • Found out that this must be a server configuration issue.
    I made a 1:1 copy on another server and this still hasn’t worked but then I tried a workaround I found:
    – Using feedburner to fetch the feeds and then let WP RSS Aggregator fetch from feedburner
    – This worked on my second server but not on the main server – even with a fresh WP installation.
    – I tried a third RSS Feed Plugin which has exactly the same issue so there must be some sort of library issue? 1 worked for all feeds, 2 doesn’t work (or just work on certain server)

    I thought about encoding issues but I’m really not sure.
    For this feed: http://feeds.feedburner.com/UkPublishingPerspectives

    The debugger shows:

    [17-03-2016 19:05:04] [Error] WPRSS > wprss_get_feed_items:
    Failed to fetch feed "http://feeds.feedburner.com/UkPublishingPerspectives". This XML document is invalid, likely due to invalid characters. XML error: Not well-formed (invalid token) at line 1, column 1

    Which makes no sense.. like 1 column 1 is:

    <?xml version="1.0" encoding="UTF-8"?>

    Fixed it!

    I would recommend to put this in your FAQ since this cost me 4 hours!

    I had to change my “Feed Request Useragent” for whatever reason (the info is ‘some servers react in unexpected ways’ but this is really far from obvious..

    I randomly set it to

    Mozilla/5.0 (iPad; U; CPU OS 3_2_1 like Mac OS X; en-us) AppleWebKit/531.21.10 (KHTML, like Gecko) Mobile/7B405

    After that it just started to fetch every feed.

    What a nightmare…

    Hi,

    I apologize for the delay in reply. Glad that setting the Feed Request Useragent option worked out for you.

    Regards

    Thank you kairoeder!

    That fixed my issue as well!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can't import feed from a w3c valid xml’ is closed to new replies.