Support » Plugin: CSV Importer » Can't import anything but example files

  • I’m using this plugin to import some data into a site that uses quite a number of custom fields (associated with a custom post type). The first time I tried it, when it didn’t work (returned the error that posts were skipped “most likely due to empty title, body and excerpt”), I assumed it had something to do with the relative complexity of the fields/post type.

    However, I’ve spent the better part of an hour working on this, and I haven’t been able to get a single file to import except the sample one.

    I’m working on a Mac using Excel 2011. Since some people suggested in previous posts that Excel might cause problem with the way it creates csv files, I’ve tried copying/pasting data into a Google spreadsheet and importing a CSV form there. That didn’t work either.

    I then tried simply opening up the created CSV files in TextWrangler and comparing them to the example files. At face value, there is no difference — all are encoded in UTF-8 with LF line breaks. But only the example ones will import.

    I’ve tried using only wpv-post-title as well as using wpv-post-title, wpv-post-post, wpv-post-excerpt, wpv-post-categories as column headers. None of these make any difference.

    I started with the version of the plugin that is available in the Repository (0.3.7), but I’ve also tried the version that bheadrick mentioned he had forked and improved on GitHub (0.3.9). Upgrading didn’t make any difference.

    I strongly suspect at this point that I’m dealing with an encoding issue, but I’m at a loss of how to address it.

    I’d appreciate any advice anyone might have to offer!

    Edit: updated to add that I’ve stripped out all of the complex data from my initial spreadsheet at this point. I’ve literally tried just creating a csv file from scratch in TextWrangler with one or two fiels and one record. Even that won’t import.

    http://wordpress.org/extend/plugins/csv-importer/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I think the plug-in does no longer work with new versions of WordPress.

    My uploads are always empty, though they used to work.

    I upload in Greek.

    Please correct me if Im wrong.

    I know I’m replying to old posts, and you guys have probably figured out a way to achieve what you were trying to do, but I want to point out a couple of things:

    1. The plugin still works like a champ. I’m still using 0.3.7 on the newest versions of WP. I know there is 0.3.8 out there now, but I was hesitant to use it since it just showed up out of the blue.

    2. @mburtis, I notice you’re mentioning headings like “wpv-post-title, wpv-post-post, wpv-post-excerpt”. I don’t think these are gonna work with this plugin. For the standard WP fields, these should be “csv_post_title, csv_post_post, csv_post_excerpt”. Looking at my import files, these don’t change even if you are using a CPT.

    You’ll also need to specify what you’re trying to import such as a post, a page, a CPT, etc using “csv_post_type”.

    Your custom fields may have any types of prefix and separator (- or _) depending on what plugin you use to generate them. You should be able to see them by looking at one of your CPT entries or by looking at the postmeta table in your database.

    If you’re still trying to get this to work, I would suggest skipping the custom categories at first as they can be troublesome with the trouble shooting. Try just csv_post_type and csv_post_title first to see if you can get those two fields to work, and build up from there.

    Has anyone gotten this to work? I just tried 037 and 038 versions. Only the sample files work.

    Thx,
    Jeff

    David Sharpe

    (@davesharpedotcom)

    Just thought I’d chime as I was having a similar problem. I had created an import file with Excel and nothing would import. Always came up with a goose egg after trying to import the CSV.

    I opened my CSV file in BBEdit, did a Save As with LF line breaks and UTF-8 encoding and it worked perfectly.

    I use Excel (Mac) about once every six months so I assume it was adding some overhead or I just don’t know where the settings are to save a correctly formatted file for this purpose.

    LgmTaylor

    (@lgmtaylor)

    HI, I am also working on Excel for Mac and was having the same issue. But managed to get it to work.

    If you click ‘Save As’, then press the ‘Format’ Dropdown. I chose ‘Windows Comma Separated (.csv) which is further down the list. Then closed the file before uploading and it worked.

    Hope this helps someone.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't import anything but example files’ is closed to new replies.