Support » Networking WordPress » Can’t import

  • Resolved satomom


    Hi there –

    I’m unable to import the small xml file from into a new blog set up with wpmu/wp 3.0 as a subdomain. When I choose the file to import, I see this message:

    “Sorry, there has been an error. The uploaded file could not be moved to /var/www/vhosts/” where “domain” is my own URL.

    Permissions are set at 755 and have also tried 777. The size of the xml file I’m importing is 180 KB.

    Can anyone help me figure this out — I’m completely stumped. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Does the folder actually exist?

    It might be there all the way down to the /1/ but not be able to create the subfolder or write to it.

    Yes, I can see the folder “2” when I look in blogs.dir.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Is there a /files/ folder underneath it? If not, create it.

    Yes, it’s already there. But oddly, it wasn’t there earlier when I looked for it. But I just created a second blog on the domain and suddenly it’s there. Let me see if import works now…

    Still not working. All permissions temporarily set to 777, including /2/ and /files.

    Got it working! I turned safe mode off at the server and that did the trick. Phew.

    Thanks, Andrea, for such prompt help when I posted here.

    Hi again –

    Ok, a similar problem has cropped up again today, for a different networked blog I’m importing into my mu installation. Safe mode is still off.

    Today I’m getting an “unable to create directory” error message. Yesterday I had this same problem initially and called my host to have them set ownership of /2/ to match the ownership of my other directories in the main domain. That fixed it. So I called them to do the same for the new blogs’ directories (e.g., /blogs.dir/4/) but the ownership was already correct.

    There’s also another variation from yesterday. Whereas yesterday the directory in which wpmu wanted to put the import blog was …/wp-content/blogs.dir/2/files, today for the new blog it wants to put it in …/wp-content/blogs.dir/4/files/2010/06. I know the 4 is correct, but can’t figure out why it wants to put it in a year/month subdirectory. Permalinks are set to %postname% only. I assume I don’t really want the entire blog imported into a year/month subdirectory, right?

    Can anyone help me? I’m stumped again! Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t import’ is closed to new replies.