Support » Plugin: qTranslate X » Can't hide the non-existent language posts

Viewing 14 replies - 1 through 14 (of 14 total)
  • I got the similar problem.

    qTranslate-X put both languages on one page:

    http://www.hudenko.com/%D0%BC%D0%BE%D1%8F-%D0%BA%D0%BD%D0%B8%D0%B3%D0%B0/

    Please help me too!

    Plugin Author John Clause

    (@johnclause)

    Hi @nibbs: It seems that you created different posts for different languages as it is shown on http://tinypic.com/view.php?pic=2qjhroo&s=8#.VKL0KV4CA

    qTranslate-X is designed to keep one post to hold all languages, and editors have language switching buttons. Will your problems disappear if you put all languages in the same post?

    Hi @justina.hudenko: did you also multiply post by the number of languages, or your problem is something else? Which theme do you run then?

    hi John, thank you for response

    I have Twenty Ten theme.

    This problem appear not for posts, but for pages and not for all. For example this one appear correctly http://www.hudenko.com/biografija/
    but I does not see the difference between 🙁

    Plugin Author John Clause

    (@johnclause)

    Hi @justina.hudenko: One difference, I see, is that slug of broken page is not in latin: “моя-книга”, while “biografija” is all latin. I am not sure if it matters. Also it is unusual to have RU capitalized for language code. I would make it lower case, but it should not be a problem, just might work better for SEO, I think. I will be on vacation for the next week. Please, let me know if slug in latin helps, and I will respond in a week or so. Thanks.

    hi John, thank you for answer.
    but I mean: I have three posts,
    one post only have english language,
    one post only have chinese language,
    one post only have deutsch language,
    if my wordpress default language is english,I hope only have english language post can see,
    if my wordpress default language is chinese,I hope only have chinese language post can see,
    As in the following picture:
    http://i62.tinypic.com/kcf4ic.jpg
    default language is english,
    In theme’s home page,
    only show have english language post,
    It good, that I want.
    but in post detail page,
    As in the following picture:
    http://i60.tinypic.com/5n4or6.jpg
    all language post is show,that not I want.

    So, the post detail page or other page can like home page only show have default language post?

    Sorry, my english is very bad , but i hope you can understand i mean.
    thanks!

    Hi John and Happy New Year!

    Thank you for response. But I was not succeed 🙁

    I made slug “моя-книга” in latin – http://www.hudenko.com/LV/my_book/
    I tried to made RU and LV in lower case as well, but the menu work had problems, so I corrected it back.

    What can I do more?

    Plugin Author John Clause

    (@johnclause)

    Unfortunately, I still cannot reproduce this behavior. It may be some conflict with other plugin which I do not have. Maybe it is a PHP version difference or WP version difference.

    We will release a new version soon with quite a few changes, let us see if this will go away. If not, we will continue researching it and I will need a list of all plugins you use, and all versions.

    You may also try turning off some other plugins and see if it helps meanwhile.

    Plugin Author John Clause

    (@johnclause)

    Hi @nilbbs, ok, I understood your problem and I believe this feature is not yet implemented. I will have to put it in todo list. How would you estimate the priority, is this something really important for you?

    I would think that people would still wish to know that there are posts in other languages, since they can translate on their own, if they want to. But you would eliminate an opportunity for them to know about new posts in other languages.

    The option you mention affects searches only, but not recent posts. We need another new option for that. Please, let me know if you still want it badly.

    @justina.hudenko: I think your problem is different, and I cannot reproduce it. If you still have in in the latest version, please, try to give me more relevant details.

    Plugin Author John Clause

    (@johnclause)

    @justina.hudenko: I just tried to check if your problem is solved, and see that page http://www.hudenko.com/en/my_book/ still shows two languages. However, you are using mqTranslate and not qTranslate-X. Was it like this from the beginning or you switched recently? Please, let me know if you still have a problem with the latest version of qTranslate-X.

    P.S. BTW, do you by any chance have “more” or “nextpage” tags in the texts? I have seen reports on them not working properly.

    Plugin Author John Clause

    (@johnclause)

    Hi @nilbbs: The latest trunk version, 2.9.7.4, on GitHub https://github.com/qTranslate-Team/qtranslate-x might fix your problem. Here is a download link for the sake of convenience.
    Do you mind testing it before it is released to public?
    Thanks a lot.

    Dear John, I have migrated to qTranslate-X, but seems that I have lost all my Russian content, my menu doesn’t work properly, I have lost all my pictures and there are no flags to change language…

    I have also tried to import my settings from mqTranslate, but it did not react

    What did I do wrong an how to fix it

    @justina.hudenko: I think your problem is related to the fact that the current version does not import correctly the setting from mqTranslate.

    You have two options:

    1. Revert back to mqTranslate until a fixed version of qTranslate-X is released
    2. Copy all your settings from mqTranslate to qTranslate-X by hand and try. If it does not work yet, fallback to the first solution.

    sorry, but I don’t understand what does “Copy … by hand ” means. Could you please explain it in more details.

    Plugin Author John Clause

    (@johnclause)

    Hi @justina.hudenko: you may try using the latest version from GitHub, which you can download with ‘Download ZIP’ button on GitHub page or press here for the sake of convinience. This version will most likely become 3.1 release.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can't hide the non-existent language posts’ is closed to new replies.