Support » Plugin: WPBook » Can't grant permissions. Blog fully shows inside canvas url

Viewing 11 replies - 1 through 11 (of 11 total)
  • Happy New Years. Do you think there is a conflict somewhere? Can you tell by looking at the page? I have almost no plugins involved and when I deactivate them I still have the same problems.

    Plugin Author John Eckman

    (@johneckman)

    Not sure where the issue here may be. It’s possible things have changed again.

    What’s interesting is that visiting the app page itself ( https://apps.facebook.com/foreverhair/ ) no longer requests permissions, which means the app itself doesn’t have permission to access info about who is logged in to Facebook.

    That’s a problem, because when you visit the “check permissions” page ( https://apps.facebook.com/foreverhair/?is_permissions=true&wp_user=1 ) it tries to look up what userid you are logged into facebook as in order to create the right “grant permissions” dialogue link.

    Previously just visiting that app canvas page was enough to trigger the basic permissions, which then allowed the app to get the info it needs (“you are logged in to Facebook as”) in order to construct the correct grant permissions url.

    Was this a new install of an existing install?

    If you go look at your settings in Facebook (your account settings) do you see the “Forever Hair Blog Comments” app listed as one of the apps to which you have granted permissions?

    Plugin Author John Eckman

    (@johneckman)

    Can you try this?

    Replace “yourclientid” in the link with your app id and then visit this link (customized for your app):

    https://www.facebook.com/dialog/oauth?client_id=yourclientid&redirect_uri=https://apps.facebook.com/foreverhair/?scope=read_stream,publish_stream,manage_pages,user_groups

    Visiting that link should regrant the necessary permissions, then I can try to figure out how to check for that condition to begin with – and ask for initial permissions when that page first loads.

    Hey there John,

    This is a brand new install. I tried your suggestion and it still did not trigger permissions prompt for me. Even when I commissioned the app it did not ask me to grant permissions. I created the app just before the new year.

    This is the URL I attempted to use. https://www.facebook.com/dialog/oauth?client_id=562797383788695&redirect_uri=https://apps.facebook.com/foreverhair/?scope=read_stream,publish_stream,manage_pages,user_groups

    Also when I try that link it says:

    The parameter redirect_uri is required

    Plugin Author John Eckman

    (@johneckman)

    Hmm. When I click on the link directly from your forum post above it did allow me to grant permissions, and your app then did show up in my list of apps on my account settings in Facebook.

    The error doesn’t make sense since there clearly is a redirect_uri parameter on the link.

    Did you edit the link somehow? is it possible you had & where only an ampersand should be?

    thats strange. it just worked for me too. Is there a way to grant permissions to the fanpage?

    Plugin Author John Eckman

    (@johneckman)

    Ok, so the link worked, so now what do you see when you go back to the “check permissions” page?

    https://apps.facebook.com/foreverhair/?is_permissions=true&wp_user=1

    that worked. Fanpage now has permissions. Wonder what could have caused that 🙁

    Thanks a bunch for everything John.

    Last question, is there a way for me to force the previously posted blogs to post to the fanpage timeline? There are only 4 entries. I’d like to import them into facebook using WP Book instead of posting a regular link.

    Plugin Author John Eckman

    (@johneckman)

    You can unpublish them (edit, change status back to draft, save, then publish again) to force them onto fan page timeline.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can't grant permissions. Blog fully shows inside canvas url’ is closed to new replies.