Support » Plugin: WP RSS Aggregator » Can’t go to next page, returns 404 error

  • Resolved esiebert7625

    (@esiebert7625)


    Hi there,

    I just installed this plug-in to try it out before diving in and going further with it and I cannot get the next page functionality to work when the number of rss items exceeds the feed display limit. What happens is when I click older posts I get a 404 error and the URL has a ?paged=2. Now if I manually correct that to say ?page=2 it works OK. Why does the URL in the older posts link say paged? This is a new install of WordPress and the plug-in, tried it with a few different themes and it does the same thing. I tried saving Permalinks several times, my permalink type is set to Plain. What am I doing wrong? You can see if for yourself at http://ericsiebert.com

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi esiebert7625,

    Have you tried other permalink type instead of “Plain” and re-save it again? Did it work? Please let us know the result.

    esiebert7625

    (@esiebert7625)

    Hi there, I changed it post name and the older entries link changed to /page/2/ and saved it but I still get a 404 error. I changed it back to plain and saved and also 404 again. I am using the [wp-rss-aggregator] tag in a post (not a page) and it is the only post on the site. Not sure what else to try, I really like the plug-in and had planned on buying one of the add-on bundles if I can get this to work.

    esiebert7625

    (@esiebert7625)

    I tried this using a page instead and it worked just fine, not sure why the post method won’t allow you to page. When I use the page method the URL is ?page_id=2&paged=2 when I use the post method it is just &paged=2

    Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi esiebert725,

    Thanks for reporting this to us.

    We’ll further investigate this case and confirm it with our developers if necessary.

    Do you still need it to work on a Post, by any chance? Or does it work on a Page is fine for you?

    esiebert7625

    (@esiebert7625)

    I think this worked out for the best doing it as page. I tried many things and never was able to get it to work as a post, it’s working great as a page though

    Hi there,

    Thanks for the post. I found this one, because I have the same problem. Is there now a solution, as I can use permalink “Simple” instead of “Post name” without the 404 error comes? I also use a category page.

    Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi @mpr92,

    Can you please send us a screenshot of your Permalink setting so that we can also try it from here?

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.