Support » Plugin: ARVE Advanced Responsive Video Embedder (YouTube, Vimeo, HTML5 Video ...) » Can’t go to 9+ without video breaking

  • We’re trying to troubleshoot what may be preventing us from going to the latest version of the plugin. We are using regular video throughout the site, but what we’re having trouble with is a background video in our custom theme. We’re using the following shortcode…

    [arve url="https://gtc.clientsitetest.com/wp-content/uploads/gtc-vid-hm.mp4" mode="normal" autoplay="yes" controls="no" loop="yes" muted="yes" /]

    Basically, what happens when we go to any 9+ version is the video will not play ( it’s stuck on the first second) nor will it fill the whole background (it will only go to the size set in “Align Maximal Width”). So any input on how to get it to fill the whole background space like it does when we’re running the older version would be great.

    We’ve also put that same code into a test page where it’s not a background: https://gtc.clientsitetest.com/test/ The video does play, which leads us to believe there is a conflict somewhere in our code with the latest version of the plugin, but not the older version where everything works fine. Without being familiar with this plugin, we’re not sure what that might be. So any input on that would be appreciated.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Nico

    (@nico23)

    The https://gtc.clientsitetest.com/test/ page has 9.0 running and is working correctly so what is this supposed to show me? You need to inspect the HTML of the site and find out what was changes when you switch to 9.0 and show me an actual test page where the video does not play.

    (it will only go to the size set in “Align Maximal Width”)

    Well yeah that is the point of the setting, do not use align or override the max width with the maxwidth short code parameter. Also, the default Maximal Width is set to what your theme sets as $content_width and if not set by the theme it defaults to 900px. So you may have to set that as well. Your “background” is probably bigger than the content area, so you probably need to overwrite it anyway.

    Use the support site and create separate questions for each of your issues and provide ALL the info asked, and you will get help from me.

    https://wordpress.org/support/topic/official-free-support-only-at-nextgenthemes-com-support/

    Thread Starter jvmedia

    (@jvmedia)

    The “link we need help with” has https://gtc.clientsitetest.com/ So I wrongly assumed you would know I was referring to the home page.

    We put a high number (2600) in the Maximal Width field as an overwide for the content width. The Align Maximal Width also has the same number. That did adjust the background video size, but the video is still “stuck” on the home page (still plays fine when embedded into the regular page https://gtc.clientsitetest.com/test/).

    As for the html … this is the code on the testing website:

    <div class="vid expanded row herobg small-order-1 medium-order-1 large-order-2 align-right">
            
    <div class="arve aligncenter" data-mode="normal" data-provider="html5" id="arve-html5--25ffcfd450c2c8929016820" style="max-width:2600px;" itemscope itemtype="http://schema.org/VideoObject"><span class="arve-inner">
    <span class="arve-embed"><meta itemprop="contentURL" content="https://gtc.clientsitetest.com/wp-content/uploads/gtc-vid-hm.mp4">
    
    <video controlslist loop preload="metadata" data-arve="arve-html5--25ffcfd450c2c8929016820" class="arve-video fitvidsignore" muted><source type="video/mp4" src="https://gtc.clientsitetest.com/wp-content/uploads/gtc-vid-hm.mp4"></video>
    </span>
    </span>

    Vs. the code on the live website (where we’re still running the older version of the plugin) where everything is working:

    <div class="vid expanded row herobg small-order-1 medium-order-1 large-order-2 align-right">
            <div class="arve-wrapper aligncenter" data-mode="normal" data-provider="html5" id="arve-httpswwwthegaytherapycentercomwp-contentuploadsgtc-vid-hmmp4-2" style="max-width:2600px;" itemscope itemtype="http://schema.org/VideoObject"><div class="arve-embed-container" style="height:auto;padding:0"><video autoplay controlslist loop preload="metadata" width="480" height="270" src="https://www.thegaytherapycenter.com/wp-content/uploads/gtc-vid-hm.mp4" class="arve-video fitvidsignore" muted="automuted"></video></div></div>
        </div>

    I hope that is the info you need.

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can’t go to 9+ without video breaking’ is closed to new replies.