Support » Plugin: Zoomify embed for WP » Cant get zif file to display

  • Resolved budfwaldo

    (@budfwaldo)


    Hello, Are you still supporting this plugin?

    Trying to use the plugin but can’t get the zif file to display. I have checked the formatting of the url etc, I don’t see anything wrong but I may be overlooking something.

    the shortcode I use is:

    [zoomify file=”http://waldo.photography/wp-content/uploads/2018/08/0467-c-Panorama.zif” skin=”Default” zoomlevel=100]

    I am using the ZoomifyImageViewerFree-min.js file.

    What I am getting is:
    http://www.waldo.photography/?page_id=5839&preview=true

    Any suggestions welcome. I have quite a few panorama photo’s I would like to display with zoomify.
    thanks

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author SdeWijs

    (@sdewijs)

    Hey, thanks for using the plugin.

    As explained in the description, if you copy the shortcode from the example, you need to replace the double quotes in the editor. Valid doublequotes are ""and not ””.

    Regards,
    Sander

    • This reply was modified 3 months, 1 week ago by SdeWijs.
    • This reply was modified 3 months, 1 week ago by SdeWijs.
    Plugin Author SdeWijs

    (@sdewijs)

    I updated the description so that the example shortcode is now formatted with the correct double quotes.

    Thanks Sander for the awesomely quick response!

    I have copy/pasted the quotes you used in your response, but no change. It looks like Zoomify is just not finding the file.
    I get the following message temporarily displayed in the zoomify window:

    “Error related to network status – 404 not found”

    I am using the free version of Zoomify, does it matter which version I select in the dashboard? I used Express.

    I’m sorry to be such a bother, but could you take a look in the site if I add you as a user? Administrator rights?

    thanks
    Waldo

    Plugin Author SdeWijs

    (@sdewijs)

    You could try one more thing, please use the code below, because the zoomlevel also needs to be in quotes.

    Another thing is that your .zif file simply does not exist in the specified location. If I use the link http://waldo.photography/wp-content/uploads/2018/08/0467-c-Panorama.zif, it should download the zif file, but as you also saw, a 404 is returned. So please make sure the zif file is exactly in the location and has exactly the same name.

    [zoomify file="http://waldo.photography/wp-content/uploads/2018/08/0467-c-Panorama.zif" skin="Default" zoomlevel="100"]

    budfwaldo

    (@budfwaldo)

    Hello Sander,

    I have tried everything and still no luck. There was a typo in the url, as you suspected, which is now corrected. When I copy it into safari it downloads the zif file, so it is now correct. I have changed the js file to the express version since I discovered that the converter I have is that version. I have replaced the ” marks with copy and paste from your post. No luck.

    I would really like this to work.

    Anything else I could try?

    Thanks for all your help.
    waldo

    Plugin Author SdeWijs

    (@sdewijs)

    The console on your page shows an error:
    Access to XMLHttpRequest at ‘http://waldo.photography/wp-content/uploads/2019/08/0467-c-Panorama.zif?t1567354948689n0’ from origin ‘http://www.waldo.photography’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

    What this means is that you are both using the www, and non-www variant in your site’s configuration and the shortcode. For the code, these are considered two separate domains. And for security reasons, JavaScript requests across domains are blocked by default. If I inspect the generated code from the shortcode it shows:

    Z.showImage("zoomifyContainer-0467-c-panorama", "http://waldo.photography/wp-content/uploads/2019/08/0467-c-Panorama.zif", "zSkinPath=http://www.waldo.photography/wp-content/plugins/zoom-image-shortcode/assets/Skins/Default/&zNavigatorVisible=1&zToolbarVisible=1&zSliderVisible=1&zLogoVisible=1&zFullPageVisible=1&zProgressVisible=1&zTooltipsVisible=1");

    The link to the zif file points to http://waldo.photography/etc. and the zSkinPath (generated by the code using the configured base URL in your sites settings) says http://www.waldo.photography.

    So please check what is configured at you WP site’s general settings. And make sure you use exactly the same URL notation in your shortcode.

    • This reply was modified 3 months ago by SdeWijs.
    budfwaldo

    (@budfwaldo)

    Genius! Now works! Thank you so much!

    One more question:

    Is there a way to set different viewer sizes locally, different on each page? Or different for each viewer?

    Thanks for your tremendous support. This is a brilliant plugin and I will be using
    it extensively on my site.

    regards,
    Waldo

    Plugin Author SdeWijs

    (@sdewijs)

    Great to hear it Waldo! One of the reasons I created this plugin is to support the creative community.

    Each viewer has it’s own unique id, so you can use this to add custom styles to your theme for each viewer. The id is always zoomifyContainer- + the filename of your .zif file, minus the .zif.

    For example, if your filename is babblingbrook.zif, the ID of your viewer would be #zoomifyContainer-babblingbrook. So in your theme’s CSS you could add something like:
    #zoomifyContainer-babblingbrook {max-with: 300px;}

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.