Support » Plugin: Podcast Player - Your Podcasting Companion » Can’t get translations working

  • I’ve translated some of the plugin, using the .pot file and creating podcast-player-da_DK.po & podcast-player-da_DK.mo files.

    For some reason my changes are not visible in the plugin. What could I be doing wrong? I’ve cleared all caches and tried disabling and re-enabling the plugin.

    Also, how do I hand over the translations to you when I’m done?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    Thanks for the translations.

    Where have you put the translation files? Are you using some sort of translation plugin?

    If not, you can try Loco Translate free WordPress plugin. Setup instructions are available on https://www.wpbeginner.com/wp-tutorials/how-to-translate-a-wordpress-plugin-in-your-language/(Choose Method 2 on this page).

    Also, ensure that,
    1. You have changed WordPress default language from English to your native language in WordPress Dashboard > Settings > General ( Look for “Site Language” section).

    2. While adding “New Language” in Loco Translate for Podcast Player, make sure to select first “Custom” radio option in Choose a location option.

    If you would like to contribute in translating Podcast player for everyone, you can get started by visiting WordPress translation handbook at https://make.wordpress.org/polyglots/handbook/tools/glotpress-translate-wordpress-org/

    Please inform if you need more help on this OR if any other help is required.

    Thanks,

    Thread Starter Squazz

    (@squazz)

    I put the files in the /lang folder.

    I’ll try out Loco Translate. If nothing else it can help me translate directly from WordPress 🙂

    I’ve started adding some contributions here: https://translate.wordpress.org/projects/wp-plugins/podcast-player/stable/da/default/
    I don’t know if that’s the right place, the instructions from WordPress are pretty vague :/

    Thread Starter Squazz

    (@squazz)

    Installing the Loco Translate plugin it already found my danish translations, so aparrently the file is there, and is registered correctly?

    Plugin Author vedathemes

    (@vedathemes)

    Hi,

    If it is working correctly, probably you are doing everything correctly. You’re right that translation instructions are not quite clear on WordPress.

    Please inform you findings once you successfully achieve the translation. Or inform if you need more help.

    Thanks,

    Thread Starter Squazz

    (@squazz)

    Just completed the translations with Loco Translate, and uploaded the changes to this page: https://translate.wordpress.org/projects/wp-plugins/podcast-player/stable/da/default/

    Still, I havn’t been able to get any of the texts to show on the shortcode player.

    Thread Starter Squazz

    (@squazz)

    Just played around with the widget, my translations didn’t work there either.

    Plugin Author vedathemes

    (@vedathemes)

    Hi,

    Just one thing, WordPress translation (on https://translate.wordpress.org) and Loco Translate on your personal website are two different things. If you are using Loco Translate properly, translation should appear without doing anything on translate.wordpress.org website.

    Please ensure that you have set up loco translate correctly (and also note two points I mentioned in my previous comment).

    Thanks,

    Thread Starter Squazz

    (@squazz)

    I see I should have been more concrete. Using the Loco Translate plugin and using the location setting “Author” (placing the files in plugins/podcast-player/lang/podcast-player-da_DK.po) won’t work. I guess this is where you’ll add your translation files as they are made?

    Relocating the files to “Custom” (using the location languages/loco/plugins/podcast-player-da_DK.po) the translations work.

    So, for some reason, the translations doesn’t work if they are in the “Author” location. What I would consider the “correct” location. I’ve never experienced this with themes or other plugins that I’ve translated. But then again, I’ve never used Loco before, I’ve just used Poedit and handled the files manually.

    • This reply was modified 2 years, 2 months ago by Squazz.
    Plugin Author vedathemes

    (@vedathemes)

    Hi,

    What you do with other plugin and themes should also work with Podcast player. Can you provide your translation files and exact steps that you followed (with other plugins)? I will check those steps with my installation and check why this is not working. However, it might take a day or two.

    You can provide translation files on contact@vedathemes.com

    Thanks,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t get translations working’ is closed to new replies.