[resolved] [closed] Can't get to dashboard of addon subdomain multisites (17 posts)

  1. hanger3
    Posted 5 years ago #

    I started off with 3.1 RC4 and set up a multisite setup. I was able to do things properly. I could get to the dashboard of all the sites that I've created. But now since I've upgraded to final version of 3.1, I can't log in to any other site, except for the main site. When I click on the dashboard of any other setup, I get taken to the login screen. I try to log in, but it doesn't go anywhere.

    But I can still log back in to the main domain.

    So I can do everything, and see everything in the back end, just as long as I don't go to try and manage another site in my setup.

    And like I said, it was working fine when it was 3.1 RC4, but the final 3.1 broke it.

  2. Ipstenu (Mika Epstein)
    Posted 5 years ago #

    I try to log in, but it doesn't go anywhere.

    Can you elaborate? Does the screen shake or ... what?

  3. hanger3
    Posted 5 years ago #

    Sorry. It basically just refreshes the page. It doesn't tell me anything. Its like I've hit the login page for the first time again. I did try to log in with random characters, and the login box does shake. So it does know that I am a registered user. Just just won't take me anywhere except for the login screen for that domain.

    I've looked at the config file, and it looks proper. But i suppose it wouldn't even let me see the other sites in the dashboard when I'm logged into the main domain. I haven't checked the .htaccess file yet. But upgrading to WP 3.1 wouldn't change the .htaccess file would it? I did set up the multi-site while the current version was RC4. Should I start all over with the setup from 3.1?

  4. Ipstenu (Mika Epstein)
    Posted 5 years ago #

    No, let's not start over yet :)

    Turn off all your plugins for starters.

    Delete all your cookies and then log in again.

  5. hanger3
    Posted 5 years ago #

    I'll try this later tonight since the main domain is still a live site, and uses plugins to function correctly.

  6. woody24
    Posted 5 years ago #

    Plugins disables, cookies and cashe removed. Still not getting in.

  7. woody24
    Posted 5 years ago #

    I've figured out that it has to do with the domains. Logging in to the main domain gives me access to the network sites admin. But when I try to switch over to another sites dashboard, it won't let me log in to it.

    But I've found that this is only for the sites that I have another root domain pointed to it. If I create a new site, and just leave it as a sub-domain, it works. But when I convert that subdomain to look like another domains, thats when I can't get into the back end of that site. But the front end still works.

    But this has only happened since upgrading to the full WP 3.1. RC4 didn't have this issue.

  8. woody24
    Posted 5 years ago #

    So DOMAIN.com is the main domain.
    I create and can log into domain2.domain.com's back end. But when I edit the site info and tell it to be DOMAIN2.com instead, thats when it doesn't work.

  9. Yes, because you're doing it wrong.

    If you want to use a different domain for a second site, do not edit the details manually. Use the plugin.


  10. woody24
    Posted 5 years ago #

    That actually sounds like more work than how it worked before.

  11. woody24
    Posted 5 years ago #

    Alright. I've tried to use that plugin, and I don't understand it. It doesn't work. I'm not sure what all I need to put in the fields.

    And the way the plugin sounds, it sounds like this is if I want to host other peoples sites. There are all my own sites, using my own domains, all on the same server.

    I just don't understand why I can't see the backend of the other domains. The front ends work perfectly fine. I can view them, I just can't get into the backend.

  12. It does work, I use it. I write docs on it. I test it for others on a weekly basis. I use a variation of it for my own sites. Daily.

    You can use it for what you want.

    the reason you can't login to your other domains after changing them manually if because you don't have any other code to help handle the different domains. Which the plugin has.

    Not understanding how to use it is fine. This does not mean the plguin doesn't work or won't be useful to you.

    It does and it is.

  13. woody24
    Posted 5 years ago #

    Can you point me in the direction of what the fields mean, and what I need to put in them? I'm on shared hosting, I put in the only IP address I could find for my site.

    And I don't even know what an ANAME or CNAME is. I couldn't find anyone explain what exactly needs to go in there to make it work.

    I don't know, maybe its just me, but this seems overly complicated for what it needs to be. I do have someone elses WP hosted on my server. I set them up with their own install. Locally the files see http://theirsite.mydomain.com, but in the settings in WP, I was able to switch it in one place to http://theirsite.com. And it works just fine without a plugin. I was hoping to do the same here.

    I thought I'd cut down on databases by setting up a multi-site, but at this point, I'll probably just go back to individual installs.

  14. woody24
    Posted 5 years ago #

    I found that page last night, but the images were broken so I couldn't see what he was talking about. Looks like its back. Thanks

  15. astromono
    Posted 4 years ago #

    Hi, I'm currently experiencing this exact issue except it started just today after more than 6 months working with multisite without problems.

    I recently installed W3 Total Cache plugin and had it running perfectly on my main domain, however I also activated it for each of my subdomains and now I can't access the subdomain's dashboards.

    I have since uninstalled the plugin and tried to access the dashboards, but it's not working. All I get when I try to access is redirect from wp-admin to wp-login, as if I'd never tried to log in in the first place.

    The only instance where this doesn't occur is with the subdomain that has Buddypress as the root. When I try to log in on that one, it just takes me to that site's index page.

  16. Please post your issues in a new separate thread.

Topic Closed

This topic has been closed to new replies.

About this Topic