WordPress.org

Forums

All In One WP Security & Firewall
[resolved] Can't get to Admin Login Page after renaming it (15 posts)

  1. gtdriski
    Member
    Posted 1 year ago #

    Using your security plugin, I just renamed the admin login page on one of my client's sites. However, now when I try the new admin URL, I just get the frontpage of the site. Prior to this, I was using other features in your plugin and everything seemed to be working fine. I need to either figure out how to make this work or how to get back into admin so I can turn the admin rename feature off. Please help.

    Thanks, Gary

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

  2. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    To get back in, simply deactivate the plugin by renaming its folder using FTP.

  3. gtdriski
    Member
    Posted 1 year ago #

    Thanks,

    I did this.

    However, I would like to get back to using your plugin with the settings I had before I renamed the login page. How do I do that?

    Also, Eventually, I also want to use the login page rename. How do I get that to work?

    Thanks, Gary

  4. mbrsolution
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi @Gary there must be a conflict with another plugin and or the feature you want to use might not work with your current configuration like server and website.

    You can try to enable all features that where working for you before you enabled this one that blocked you.

    Kind regards

  5. gtdriski
    Member
    Posted 1 year ago #

    Ok, are you saying I have to reinstall the plugin and then setup the features again?

    Is there no way to manually turn off (edit a file or edit a DB Table) the rename login feature so I can just go back to what I had?

    Thanks, Gary

  6. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Gary,
    After renaming the plugin you will be able to login to the admin panel.
    When you have logged in, re-name the folder back to the original name and then activate the AIOWPS plugin again and then go to the "Brute Force" menu and disable/change that feature's settings.

  7. gtdriski
    Member
    Posted 1 year ago #

    Hello again,

    Been away for awhile, but still haven't resolved this.

    I tried your previous suggestion, but on activation, it immediately threw me out of admin and couldn't get back in because the URL rename was still active.

    I also tried a different approach: Renamed folder, logged in, renamed folder back, clicked "Delete" to delete your plug-in. This seemed to work, so I then tried to reinstall your plug-in. However, on activation, it threw me out again, so the delete apparently didn't remove all your plug-ins settings.

    Please give me instructions to manually remove your plug-in (all files, all settings, all DB Tables, etc.).

    Additionally, we liked your plug-in and had had chosen to use it in all our client sites going forward. However, renaming the admin URL was a major feature we wanted. I would definitely be willing to help you investigate why this is not working on this site and I do have it working on other sites. We are not using a bunch of strange plug-ins on the site (Genesis Framework, Gravity Forms, All-in-one Event Calendar, etc.)

    Thanks, Gary

    [ No bumping please. ]

  8. gtdriski
    Member
    Posted 1 year ago #

    Hello,

    Please answer my previous reply. I still haven't been able to resolve this.

    Thanks, Gary

  9. mbrsolution
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi Gary after you rename the plugin folder make sure that you edit your .htaccess file by carrying out the following.....

    Locate the “# BEGIN All In One WP Security” and “# END All In One WP Security” lines and remove all lines in between (and including) those lines.

    Let us know if that works.

    Thank you

  10. mra13
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Gary, Just temporarily deactivate all plugins except this one. Are you able to log in using the renamed page then?

    Are you 100% sure that you haven't forgotten the slug you entered in the settings of this plugin?

    If you are able to log in, go to the settings of this plugin and hit the reset settings button.

  11. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    Gary,
    You should probably try clearing the aiowps settings from the options table.
    Use PHPMyAdmin and go to your options table and then delete the entry with option_name called "aio_wp_security_configs".

    This will clear all of the settings from the plugin and should prevent you from being thrown out when activating the plugin again.

  12. ri4u
    Member
    Posted 1 year ago #

    While we deactivate the plugin, it must remove all the settings.

    This particular issue also created lots of hassles in our network sites.

    While activating few issues, we too get thrown out of wp-admin and also gave internet server error 500. For for literally, each usage - we need to take backup of .htaccess. Ideally if it finds error, must resolve automatically by resetting to backed up .htaccess file.

    regards

  13. ri4u
    Member
    Posted 1 year ago #

    I tried finding in option table - but this field doesn't exist.

    Still upon re-activating the plugin (with clean .htaccess) - I am thrown out.

    Anything, I am missing here?

    regards

  14. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    If you have ever activated the AIOWPS plugin, the options table will definitely have an entry called "aio_wp_security_configs" for the option_name column.

    In PHPMyAdmin, try sorting the table by clicking on the "option_name" column and you should be able to see that row displayed near the top because it starts with the letter "a".

    When you delete this entry, all your existing settings will be cleared and you should not be thrown out anymore.

  15. GHDesign
    Member
    Posted 1 year ago #

    I was having this same problem.

    I was getting frustrated as well when looking at myPHPAdmin options table... until I realized I was only looking at page 1 of MANY pages. At the top and bottom you'll see you can select individual pages and select number of rows per page.

    I selected maximum rows, sorted "option_name" to alpha... found the aio_wp_security_configs and deleted it.

    When I reactived the plugin, I was NOT kicked out!

    Thanks, wpsolutions. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic