Support » Plugin: Google Authenticator - Per User Prompt » Cant get the plugin to work :(

  • Hi,
    I have installed the plugin, and im getting the following error:
    “Google Authenticator – Per User Prompt error: Your environment doesn’t meet all of the system requirements listed below.
    The Google Authenticator plugin must be installed and activated.
    PHP 5.2.4+ (You’re running version 5.6.8)
    WordPress 3.5+ (You’re running version 4.3.1)
    If you need to upgrade your version of PHP you can ask your hosting company for assistance, and if you need help upgrading WordPress you can refer to the Codex.”

    can you please tell me how to fix this ?

    https://wordpress.org/plugins/google-authenticator-per-user-prompt/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ian Dunn

    (@iandunn)

    Do you have the Google Authenticator plugin installed and activated? Per User Prompt runs alongside it, rather than replacing it.

    yes its installed and enabled

    Plugin Author Ian Dunn

    (@iandunn)

    Can you make a small, temporary change to bootstrap.php, to help isolate exactly where the problem is occurring?

    Replace the 3 if { ... } blocks inside gapup_requirements_met() with this:

    if ( version_compare( PHP_VERSION, GAPUP_REQUIRED_PHP_VERSION, '<' ) ) {
    	var_dump( 'php', PHP_VERSION, GAPUP_REQUIRED_PHP_VERSION ); wp_die();
    	return false;
    }
    
    if ( version_compare( $wp_version, GAPUP_REQUIRED_WP_VERSION, '<' ) ) {
    	var_dump( 'wp', $wp_version, GAPUP_REQUIRED_WP_VERSION ); wp_die();
    	return false;
    }
    
    if ( ! is_plugin_active( 'google-authenticator/google-authenticator.php' ) ) {
    	wp_die( 'plugin_inactive' );
    	return false;
    }

    Then load a page in wp-admin, and copy/paste the results here.

    After that, you can undo the changes.

    I had problems with the modifications to bootstrap.php so I deleted the Google Authenticator plugin, then reinstalled it and the per user plugin no longer shows the error and works properly again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cant get the plugin to work :(’ is closed to new replies.