Support » Plugin: Strong Testimonials » Can’t get testimonials horizontal

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Chris Dillon

    (@cdillon27)

    Hi,

    Try clearing your Autoptimize cache. You may also need to disable the Autoptimize JavaScript options.

    Concerning Autoptimize: as a quick test you can disable AO on a per-request basis by adding ?ao_noptimize=1 to the URL.

    If your site works that way, then disable JS optimization for a second to see if that fixes it. If so, then you’ll probably have to add the plugin’s JS to the comma-separated JS optimization exclusion list. In that process you should keep an eye on your browser’s console for JS errors, as those will help you identify the problem.

    AO’s FAQ has more info on troubleshooting and how to exclude.

    hope this helps,
    frank (ao dev)

    Hi guys,

    Thanks for the feedback. I tried without AO (https://www.genroe.com/sample-testimonial?ao_noptimize=1) but no change – still shows incorrectly.

    (I had also cleared the AO cache as a trial before I raised this case)

    Any other ideas?

    Thanks.

    Adam

    Plugin Contributor Chris Dillon

    (@cdillon27)

    Delete and reinstall Strong Testimonials. You won’t lose any settings or testimonials. Test the page.

    On the Testimonials > Settings > Compatibility tab, try setting “Ajax Page Loading” to
    General. Test the page

    Also on the Compatibility tab, set “Load Event” to window load. Test the page.

    Chris,

    Thanks for getting back to me. Tried:

    – Delete and reinstall
    – Compatibility tab, “Ajax Page Loading” to General.
    – Compatibility tab, set “Load Event” to window load.
    – Tried the above singly and combined.

    No change. Also tried re-deleting WP Engine cache.

    Can’t see any JavaScript errors in the console.

    Suggestions?

    Thanks.

    Adam

    Plugin Contributor Chris Dillon

    (@cdillon27)

    Thanks for trying that. We can rule out the obvious. So we need to narrow down the conflict.

    Start deactivating other plugins one at a time, starting with caching and optimization. Test the page with each time. If the slider starts working then there is a conflict with the last plugin deactivated.

    If the problem occurs with *all* other plugins deactivated then it is a conflict with the theme.

    Once we identify a conflict, I will try to devise a solution.

    Chris,

    Still working this. Created a staging version of the site and deactivated all plugins.

    Problem still remains: https://genroestaging.wpengine.com/sample-testimonial

    Not sure where to from here. I’m conscious that this is a free plugin and of using your time.

    I guess I could give you an admin login to the staging site if that would help.

    Regards,
    Adam Ramshaw

    Chris,

    FYI – framework is Genesis and theme is Enterprise Pro Theme. Latest versions.

    Adam

    Plugin Contributor Chris Dillon

    (@cdillon27)

    Thanks Adam. I will start troubleshooting with Enterprise Pro.

    Plugin Contributor Chris Dillon

    (@cdillon27)

    The slider is working for me in Enterprise Pro with default settings.

    Please export your Genesis theme settings and send the .json file to chris at strongwp.com.

    In the Scripts options on the sample-testimonial page, is there anything in the Header Scripts and Body Scripts options? What is the setting for Body Scripts Position?

    Chris,

    Thanks for the update – have sent the requested data to your address.

    Adam

    Plugin Contributor Chris Dillon

    (@cdillon27)

    Thanks. I imported the file. The slider is working.

    There’s nothing more I can do. I suggest you ask Genesis support if they can help.

    Chris,

    Thanks for working through all of that. I’ll keep working through it this end to see if we can find this issue. I’ll post back here if I think it would help with the product (and isn’t just something unique to us.)

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.