Support » Networking WordPress » Can't get subdomains to work on Multisite

  • Resolved thelaw


    I’m using WHM/CPANEL and have added a * wild card entry in the subdomains portion of the cpanel and it points to the root directory. I’ve added in the appropriate entries into .htacess but I still get a server not found error message. Using Firefox I get:

    Firefox can’t find the server at

    I also notice that after adding the new site in the network control panel, it doesn’t appear in the dropdown menu. It can only be accessed by viewing all sites.

    I tried to use the WordPress MU Domain Mapping plugin to see if it would work but it does not either. I have that domain mapping plugin working on another site on the same serve but I have to add those subdomains in manually into CPANEL’s subdomain manager. I’m hoping someone can help since I am sure I performed all the steps although obviously something is missing.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I was able to manually set up subdomains in cpanel without the Domain Mapping plugin but for reasons I can’t explain, one subdomain just won’t work. Will have to try to recreate the entire site and see what happens. Still not sure about the wildcard issue to auto create subdomains.

    Problems are apparently worse than this – I can see the sites on the subdomain but can’t login to the admin panel. All new sites that get created are inserted into the admin panel but I still have “1 site and 1 user” when I go to the Network admin dashboard. I have 3 sites created. When I try to login to the back end on any of these sites at using the only user admin, I get an invalid permission. So I made every user a superadmin. Now I can login but I only get into the main site, not any of the multisites.

    This is a duplicate of this problem with no solution I can see:

    So if I login at or try to switch using the network control panel and sites and go to dashboard for the site, I’m back in the dashboard for the main site. None of the subdomains are working for the admin panel.

    I deleted and recreated the entire domain since nothing was working. Now creating subdomains and site entries in the WordPress network cpanel works. However, sites are still at “1” and they don’t appear in the dropdown menu. Everything else works it’s just an inconvenience. The above problem seems to be outstanding for some as it is for me. Perhaps this is worth looking into.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    The sites/users bit is cached, though that’s getting better with later versions of WP.

    Are the sites up and running?

    Mika – many thanks for your reply. The caching explains the problem. A day later I get 2 sites and just now I’ve gotten 3. Mostly all is now well and I’ll explain for the world (you probably know this) what I’ve experienced as well as one problem.

    As a result of the caching, any issues or errors made take time to clear until the cache is refreshed or the site owner does this manually. The proper process to create subdomains is FIRST entering the subdomain into Apache or into CPanel’s Subdomains Manager and SECOND entering the new site in a subdomain into the WP Network admin. Problems will arise if you forget and do it backwards.

    Even doing this properly – and the front and back end of sites work – the drop down isn’t appearing under “My Sites” for the extra sites. It’s a minor error and just a PITA when switching between site admin dashboards.


    Even though I have the MultiSite User Management plugin running, every new site requires the admin being used to be added to the user list – even the SuperAdmin created when first installing WordPress.

    Thanks for your generous help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can't get subdomains to work on Multisite’ is closed to new replies.