Support » Plugin: Geo Mashup » Can’t get search by zip code to work

  • This is such a great plugin. The map works fine, but I can’t seem to get the zip code/city search to work. I’m using the same Google API key for both server and API key fields within GEO Mashup settings.

    I have Geocoding and Geolocation APIs enabled in my Google account. No restrictions currently set on my API. Any ideas on what I’m doing wrong? Thank you!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Dylan Kuhn

    (@cyberhobo)

    You need to use the search widget Geo Mashup provides. There are some more details in the docs.

    Thread Starter Kyler Boudreau

    (@kylerboudreau)

    Hey Dylan, thanks for responding! I am using the widget. It used to work but quit working and I just haven’t figured out why. So decided to try posting here. Is there any specific Google API that needs to be enabled outside of normal for that feature to work?

    Plugin Author Dylan Kuhn

    (@cyberhobo)

    It works for me with only Overall / Google API Key set.

    The search widget at the URL you gave isn’t the Geo Mashup widget, do you have it somewhere else?

    Thread Starter Kyler Boudreau

    (@kylerboudreau)

    Dylan, I apologize. I’d hid the widget since it wasn’t working. It’s back on the same page now. And yes, I’m using the GEO Mashup widget. Thank you!

    Plugin Author Dylan Kuhn

    (@cyberhobo)

    It looks like you’re using a customized search results template. Does it work with the default template?

    Thread Starter Kyler Boudreau

    (@kylerboudreau)

    Hey Dylan, I’m sorry for the late reply.

    So… no, I removed the customized search results template and it doesn’t work still.

    I’ve just removed the widget from the map page. Not sure what else to do.

    Plugin Author Dylan Kuhn

    (@cyberhobo)

    That indicates there might be a bug, I’ve created [GitHub issue #882](https://github.com/cyberhobo/wordpress-geo-mashup/issues/882) to investigate.

    Thread Starter Kyler Boudreau

    (@kylerboudreau)

    Hey man – I apologize for the delay. Thanks for the help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.