WordPress.org

Support

Support » How-To and Troubleshooting » can't get rid of unwanted unicode characters!

can't get rid of unwanted unicode characters!

  • Hello helpful wordpressers,

    I’m pasting processing.js code into my blog posts between shortcode tags, using the Processing.js plugin. That part works ok, but the special characters in my posts like > < etc are getting changed to unicode, which breaks my processing code from executing. I’ve tried various plugins that disable wptexturize, and even added remove_filter('the_content', 'wptexturize'); to my theme’s functions.php. I’ve tried wrapping the code in pre and code tags. Nothings stops the characters from getting changed! But the really weird thing is, this doesn’t happen when I’m editing posts on my Mac, regardless of browser, but it happens on every other windows computer and even another Mac that I’ve tried. It’s driving me nuts! Can anyone help shed light on why this would be?

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    It’s probably not those filters but the Visual Editor that’s doing it.

    Adding hand coded HTML into the visual editor is almost always going to frustrate you. Try disabling it in your user profile and then re-edit that post.

    http://your-wordpress-url-here/wp-admin/profile.php

    Thanks Jan. I should have mentioned – this is all in happening in the HTML editor!

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    Yes, but have you tried disabling that option just to see? Using the HTML tab can cause that if you switch from one to the other.

    Disabling that in your profile and then trying to reproduce the problem may help narrow down what’s really causing it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘can't get rid of unwanted unicode characters!’ is closed to new replies.
Skip to toolbar