Support » Theme: OceanWP » Can’t get rid of “Skip to content”

  • I’m trying to see why this keeps showing up. I can hide it via CSS or disable it in header.php but highly doubt that’s the optimal way of fixing it. Is it a theme script that needs to be enabled?

    Thanks for any help.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter computerkid1

    (@computerkid1)

    Forgot to mention, this happened after updating OceanWP

    Hello @computerkid1,

    Just to clarify something first. Are you referring to the “skip to content” while logged in as an admin? Because I’m not seeing it on your website

    You’ve probably already fixed this, but this may help others.

    In my case the “Skip to content” text appeared when I disabled the Mega Menu option, which I don’t use anyway, at Theme Panel > Scripts & Styles Panel > Mega Menu.

    So once you install the plugin Ocean Extra to better manage the OceanWP options, beware of unintended (and unexpected) consequences of disabling some features.

    It baffles me why, but it does work that way.

    PS: Disabling Theme Panel > Scripts & Styles Panel > Links Effect also causes โ€œSkip to contentโ€ to appear ๐Ÿ™

    Also
    Theme Panel > Scripts & Styles Panel > Full Screen Mobile
    Theme Panel > Scripts & Styles Panel > Transparent Header
    Theme Panel > Scripts & Styles Panel > Vertical Header
    ๐Ÿ™๐Ÿ™๐Ÿ™

    Who knows what else…

    I guess the best thing to be able to disable unnecessary CSS and JS is to add custom CSS to hide the .skip-link class. It may have accessibility implications to consider, though.

    Thread Starter computerkid1

    (@computerkid1)

    @idearius Thanks for your answer. I just now realized that reply alerts from here were going to my spam.

    I just realized I have this going on with other websites. I tried enabling what you mentioned, but still having the same issue. I’ll try enabling individual scripts & styles to see what helps.

    Thanks for your reply!

    Actually disabling ANY Scripts and Styles causing the ‘Skip to Content’ link to display. So there’s a conflict with Ocean Extras?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t get rid of “Skip to content”’ is closed to new replies.