WordPress.org

Support

Support » How-To and Troubleshooting » can't get pages to show in menu

can't get pages to show in menu

  • I have tried deactivate all widgets. Tried using different themes. I have 20 pages and the only thing that shows up is home and when I click on that it says not found. What am I doing wrong? I read all 10 pages on this topic but nothing has worked. I am new to building websites. I am lost. I was able to do one website and had no problems with pages but now nothing will work on this new site. Please help. I will publish it so you can see.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Are permalinks set to default?
    Can you provide a link please?
    Can you also provide a screen shot of the dashboard Menus screen?

    If permalinks are not set to default do that now in the WordPress settings and test the home page link. Let me know 🙂

    Well I was able to do and undo the exclude pages widget and pages showed up but they don’t all fit. So what do I do now? http://www.yorkiestoluv.com

    This plugin is causing your issues however you do have the home navigation in there 2 times. I recommend removing one and then it may fit properly. Let me know 🙂

    Thanks! Did that. I want to remove the pages from the top menu and show up on side menu as I have about 26+ pages in total. How do I do that? I think that would look the best. Unless you have a sugg.?

    I only have 1 home. Can’t find the other to remove it.

    I used this widget on other site and it was able to removed the second home but this time it did not remove it. (exclude pages widget)

    I would remove the plugin entirely and then readd it to your site and setup again. There is some glitch in it. I would also recommend removing the upper menu under the WordPress >>Appearance>>Menus section

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘can't get pages to show in menu’ is closed to new replies.
Skip to toolbar