Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Can’t get NextGen to upload on XAMPP

  • Resolved forgotrafe

    (@forgotrafe)


    I’m hosting on a Windows box running XAMPP (settings below) and cannot get NextGen to work.

    If I manually create a gallery, it creates the folder just fine so I’m sure file permissions are okay.

    I’ve checked PHP.INI and I think that’s okay.

    But whenever I try and upload any image, even a tiny 15kb test image, I get:

    No permissions to upload images. Try refreshing the page or ensuring that your user account has sufficient roles/privileges.

    Thanks for any guidance!

    Server Settings
    
    Operating System : WINNT (64 Bit)
    Server : Apache/2.4.38 (Win64) OpenSSL/1.1.1b PHP/7.3.3
    Memory usage : 45.71 MByte
    MYSQL Version : 10.1.38-MariaDB
    SQL Mode : NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
    PHP Version : 7.3.3
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 250
    PHP Max Upload Size : 8M
    PHP Max Post Size : 8M
    PCRE Backtracking Limit : 1000000
    PHP Max Script Execute Time : 300s
    PHP Exif support : Yes (V7.3.)
    PHP IPTC support : Yes
    PHP XML support : Yes
    Graphic Library
    
    GD Version : bundled (2.1.0 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPEG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : Yes
    XBM Support : Yes
    WebP Support : Yes
    BMP Support : Yes
    JIS-mapped Japanese Font Support : No

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • forgotrafe

    (@forgotrafe)

    I am an administrator on the site.

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @forgotrafe,

    Usually, this type of notice reefers to the modified administrator roles that aren’t accepted to perform image uploads so respectively what I would try is to create a brand new administrator account ( priorly, you need to make sure that there aren’t any plugins or rules that are affecting the administrator role’s capabilities ) then try to login with it to see if that will allow you to upload new images.

    Please let us know

    forgotrafe

    (@forgotrafe)

    Deleting my administrator account and recreating it fixed the problem.

    Thanks @mihaiimagely

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.