Support » Plugin: Participants Database » Can’t get my ‘View’ Links to work

  • Resolved supton

    (@supton)


    I’ve added a placeholder field for a ‘View’ button to take me from the list to a single record, but I can’t get it to work. I get a 404 error page instead. I’ve gone through the instructions several times, but just can’t see what I’ve done wrong. The link looks weird as well. This is the format: new.kresy-siberia.org//5d13859365908/

    Hoping you can see what’s going on here.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author xnau webdesign

    (@xnau)

    That is kindof strange, yes. Are you using either the “Directory Tools” or “Pretty Permalinks” add-ons?

    It looks like you got the basic setup, but just to review, you must have the “single record page” defined in the plugin settings under the list display settings tab. That setting must point to the page with the [pdb_single] shortcode.

    Does the number in the URL look like any of the data in the record?

    Thread Starter supton

    (@supton)

    I’m not using either of those add ons and this is the shortcode in the individual record page:

    [pdb_single groups=”wot1,wot2,wot3,wot4,wot5,wot6,wot7,wot8,wot9,wot10,wot11″]

    The addons I have are:

    Combo Multi Search (which I also can’t get working yet, but that’s for another day)
    Datepicker
    Field Group Tabs
    Image Expansion Kit

    I can’t figure out what the link could actually be, it doesn’t represent anything in the data that I can see.

    The only thing I have done is connect my database users to wordpress users. I followed the instructions for that and got it working. I have had the ‘view’ link working before, but I have no idea what has caused it to change.

    I have also tried removing the view link and related database field, and connecting it to the last name instead but the same thing happens with the same weird link.

    Thread Starter supton

    (@supton)

    I’ve found out where the link comes from! In the database, it’s called the record slug.

    One step closer…

    Thread Starter supton

    (@supton)

    When you look closer at the link there is a double //.

    new.kresy-siberia.org//5d13885851116/

    Does that mean that part of the url is missing somehow?

    Plugin Author xnau webdesign

    (@xnau)

    What did you find when you checked the “Single Record Page” setting? It looks like that is not set up.

    Thread Starter supton

    (@supton)

    I’m wondering if there is a bug or something.

    That setting is complete and pointing to the page ‘Individual Record’ which is where the shortcode is that is detailed in my message above.

    Plugin Author xnau webdesign

    (@xnau)

    I don;t know of any bug on that functionality, something else in your setup seems to be altering the link. The “record_slug” column is added by the Pretty Permalinks add-on for Participants Database, so you should make sure you don’t have that plugin activated.

    Thread Starter supton

    (@supton)

    Well you were right. 🙂

    I was looking for a plugin called ‘Pretty Permalinks’, however I have a plugin in my list called ‘Permalinks’. Didn’t realise they were one and the same.

    I had a snoot around in there and found the setting you were talking about, so have checked that and all is well with the world.

    Thanks for pointing me in the right direction. I would never have found that on my own.

    Plugin Author xnau webdesign

    (@xnau)

    Glad to hear it, sorry about the confusion on the name of the plugin, I should have been more specific.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t get my ‘View’ Links to work’ is closed to new replies.