Support » Networking WordPress » Can't get multisite to generate pages; suspect mod_rewrite

  • Resolved shellwe


    I have downloaded the newest version of wordpress (3.4) and I wanted to create a network (multisite). I am running apache 2.2 on a windows 2008 server.
    I followed the following guide.
    I went through the steps and can create new sites and everything looks good but when I try to view them I get a 404 and I go to the folder on my server (I am creating sub-folders, not sub-domains) there is nothing there. I strongly suspect it is the mod_rewrite is not working correctly or at all. I could be missing a step, I didn’t see anywhere where you declared whether you wanted sub-domains or sub folders.
    I have this enabled in the conf file
    LoadModule rewrite_module modules/
    I load up phpinfo and it shows that mod_rewrite is on.
    But this one is NOT
    AddModule mod_rewrite.c
    Maybe that is just for Linux or something, I am not sure. In my configuration file I don’t have any other calls for “AddModule”.
    I also have this for my directory

    <Directory "C:/wwwroot">
        Options -Indexes FollowSymLinks Includes
        RewriteEngine On
        AllowOverride None
        Order allow,deny
        Allow from all

    I included the whole thing in case any of you may have noticed conflicts with the set up. The “RewriteEngine On” works but when I try to turn on even the most basic logging (level 1) Apache doesn’t start. Honestly that’s not a priority I just thought it may be needed.
    Anyway, I have been searching for hours and it is getting very difficult to figure out if a solution for Linuxis the same as it would be for Windows. We have other sites being hosted on our server that get a fair amount of traffic so even restarting Apache for a moment may interrupt their experience.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I should also note that if I click on sites and then all sites on the left panel of the dashboard I see the sites I created but if I go to visit then it doesn’t work. But along the top panel on “my sites” I don’t see all the subsites I made, just the main site. Not sure if that information helps…
    This wordpress was previously empty and I did blow away the database and reinstall wordpress to try and install it again but no luck.
    Any help you can provide would be wonderful, thank you!

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    If wp-admin pages work for your subsites, then it’s not mod-rewrite.

    Can you make posts with pretty permalinks?

    I may have mistyped that, I don’t think I can see the subsites, I hover over “My Sites” and I don’t see the sites I created; just “network admin” and the original site I had first created. I can go into the dashboard for the network admin as well as the dashboard for my original site
    The reason I suspect mod-rewrite is I go to where I have the subfolders in /blogs and there is nothing created. I created a few tests and in my sites I see a link for /blogs/test but it doesn’t work.
    As far as permalinks, I am not sure if that is working correctly. Is there a way to test it.
    Is pretty permalinks the same as “Post Name” so it looks like this?
    If so then no, it was set with default, which was the p=123. I changed it to Post Name now and tried it again but no luck
    Also, if mod_rewrite isn’t working after I do get it to work would I need to create a new wordpress and enable the network functionality or would it work automatically? My concern is there may be something that wordpress tried to do when creating the networks that didn’t happen without mod_rewrite. Of course if any of you have suggestions outside of mod_rewrite I am totally up for hearing them.
    UPDATE: I switched to the “Post Name” permalinks and now the links don’t work, so no, pretty permalinks are not working. It shows the entry on the main page but when I click on the hyperlink it doesn’t exist. I go out to the folder and those directories do not exist.

    I think I found the issue, in that directory listing I sent I think I was supposed to have allowoveride set to all.
    It shows in this post.
    I say that because I HATE when I see forum posts that match my issue exactly and there is no resolution. For some strange reason though when I hover over my sites along the top it does not show my new entry in the drop down. I’ve wiped wordpress and created the network so many times it will just take me a minute and I will see if that fixes it, honestly if it doesn’t it is not the end of the world and I will work around it.

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    I think I found the issue, in that directory listing I sent I think I was supposed to have allowoveride set to all.

    We actually mention that in the codex:

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't get multisite to generate pages; suspect mod_rewrite’ is closed to new replies.