Support » Plugin: Hana Flv Player » Can't get .mp4 to play in flowplayer5

  • Resolved The General@LTPIRGL


    I can’t seem to get the FlowPlayer5 to play my .mp4 files
    I have it playing my flv files here,

    but need it to play with apple products.

    your sample
    [hana-flv-player video=”″
    width=”400″ height=”autow”
    player=”6″ skin=”functional” /]

    plays fine and works perfectly, but when I add my url and mp4 file it says html5: video file not found.(and I have uploaded the files via ftp to the same place as my .flv file which work fine with the player)

    I have tried “any video converter, vlc player & prism converter, to create a encoded h.264 file with ACC audio and mp4 extension, but nothing has worked.
    am I missing a key step?
    Could you give any specific details as to how you created the hana_sleding.mp4 file.? or is there something in the /httpdocs/wp-content/plugins/hana-flv-player folder that I need to add to my folder that I am missing?

    Thanks for your time

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author HanaDaddy


    Thank you for the report.

    It seems that there is a problem. Not sure if the problem is with the FlowPlayer5 itself or the way I implemented it in my plugin.

    I will check more when I have time later on. Meanwhile, why don’t you try MediaElement.js (Player 5)? It sure works fine with mp4 under Apple devices.

    Thank you for your response. I initially tried using the MediaElement.js, but for some reason the player is not showing the play button, mute toggle or full screen buttons, even if you hover over them. The buttons still function, but are not visible. I tried a few adjustments, but had no luck making them appear, and it was easier to just switch to player 6 until the .mp4 problem.
    I will gladly switch players, would you have any idea on how to remedy that problem with. MediaElement.js
    Thank you again for your time and plugin

    Hello again,
    I thought i would try the MediaElement.js player with the button issue from above, just to see if I could get a .mp4 file playing, and had no luck. I took an .avi file converted it to a x264.mp4 file using the Any Video Converter(I selected the Apple I phone from the preset output and the x264 video codec from the video options). Then uploaded the file to my videos folder via ftp. The player showed my splash.jpg, but the file would not play. The counter showed 00.00 on both sides. Just wondering if I’m using the wrong settings in the Any Video Converter, or if I have missed something else completely in this process.
    thanks again

    I changed the skin and it resolved the buttons issue. I can’t seem to get the MediaElement.js to play my .mp4 files either. Like I said above the splash image shows up and the counter is at 00.00 on both sides. When you push play it holds on play and looks like its loading, but no video plays or loads. Also strange because your samples file works great.

    [hana-flv-player video=”″
    width=”400″ height=”autow”
    player=”5″ skin=”mejs-wmp” /]

    This is what I am trying on my page, but is not working

    [hana-flv-player video=” sample_x264.mp4″
    width=”420″ height=”316″
    player=”5″ skin=”mejs-wmp”autoplay=”false”
    splashimage=”” /]

    Any ideas?
    Thanks again for your time

    Plugin Author HanaDaddy


    When I tried
    “ sample_x264.mp4”

    in the web browser, it says “The page cannot be found”.
    Are you sure the file is in there? Maybe you should rename the file to something more consistent without space letter, and try again.

    thanks for your suggestions – I used fileZilla to upload after I changed the name of the file to Sample.mp4 and still it wont show up in the browser or play in the player. The same process worked for my flv files and they play and show up in the browser. My mp4 files play fine in a flv player before being uploaded. I tried it all from scratch with another newly made mp4 file and had the same results. When I opened the video folder in Smart ftp instead of filezilla it also shows the mp4 file has been uploaded, and is in the folder, but again page not found in the browser. I’m kind of stumped. Have you heard of this before?
    Thanks again for your time and any suggestions

    Plugin Author HanaDaddy


    Are you sure that you saved the sample.mp4 file in the same folder where HCPLS.flv is ? If so, you should contact your webmaster or service provider to check why mp4 files cannot be downloaded. I am not exactly sure, but it may be possible to setup the webserver to allow the access for only the files with particular extensions.

    Yes, I’m positive they are in the same folder. I have contacted them with this issue. Thanks again for your time and suggestions.

    My server added the MIME Type for the extension .mp4. The file now shows up in my browser, but with no video, just audio. The mp4 file works fine on my computer(PC), but not on my Iphone. On the phone, the Splash jpg shows up, but both counters read 00:00 and the file wont play. I tried player 6 as well, and it still said file not found on both. Any ideas?
    Thanks again

    Plugin Author HanaDaddy


    What’s the URL of the MP4 file? Let me try.

    Hello again
    my apologies for the hassle here. This is the url of the file

    [video src="" /]

    In the browser the video quality is pretty choppy, but it is normal on the site page, on my end.
    I did get it to play on my Iphone when I removed the splash jpg, but
    the quality was pretty choppy and there was no audio.

    Here is the page link again as well

    Thanks again for all of your help

    Plugin Author HanaDaddy


    Your video file is not correctly encoded I guess. I tried with my iPhone and it didn’t play well either.

    I have encoded using ffmpeg. You can check it out here. First video is yours and second one is the one I re-encoded. When I tried re encoded video using iPhone, it worked fine.

    You can download ffmpeg windows compiled version here but also you can download the one that I used here

    You need to run below command using windows command prompt
    c:\ffmpeg> ffmpeg -i HCS.mp4 -vcodec libx264 -vprofile baseline -threads 0 -acodec aac -sameq -preset fast -strict -2 output.mp4

    Note the HCS.mp4 should be your video file and the output file will be output.mp4.

    Thanks for the info, I have the ffmpeg file downloaded and tried running that command, but it said it was not recognized as an internal or external command, and this is getting a little out of my league. Is is not possible to encode a file properly with software like Any Video Converter? That is what I used, and maybe I had the settings wrong? If not, I will have to get someone to walk me through the other process.

    Thanks again for your time and help. I really appreciate it. I

    Plugin Author HanaDaddy


    Well, maybe I am using 64 bit version. If you are using 32 bit version of windows , you should download the 32bit version from the

    And I am sorry but I tried to convert your file using Any video but I was unable to generate satisfying video. I strongly suggest you to try the ffmpeg.exe again.

    Good Luck!

    It Works!
    Took a little research on google, but I got the ffmpeg going, and the end result is great.
    It is working with the flowplayer 5 as well. Thank you again, very much for your time, help and plug in!
    All the best my friend.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Can't get .mp4 to play in flowplayer5’ is closed to new replies.