Support » Plugin: WooCommerce Shipping & Tax » Can’t get live USPS rates to work

  • Resolved curiouslt

    (@curiouslt)


    Trying to get USPS live rates to work, but after trying everything in the docs and support forum, i still get the following:

    WooCommerce Service Status: No rate requests have yet been made for this service.
    Front End: There are no shipping methods available. Please ensure that your address has been entered correctly, or contact us if you need any help.

    I have zip codes set up.
    I have package weight and dimensions set up in both the Packaging settings and in my product.
    All rates are selected right now (saw in one post that made it start working for someone) – but I tried with only Priority selected as well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Mike W

    (@nixiack8)

    Hi @curiouslt,

    Trying to get USPS live rates to work, but after trying everything in the docs and support forum, i still get the following:

    WooCommerce Service Status: No rate requests have yet been made for this service.
    Front End: There are no shipping methods available. Please ensure that your address has been entered correctly, or contact us if you need any help.

    Typically this is caused by two reasons:

    – Without weight and dimensions the items can’t be packed into a box and USPS can’t say how much a box of that size and weight would cost. You covered this in stating that you have weight and dimensions set, but be sure that all of your products you are shipping have this set.

    – A Shipping Zone is not matched correctly. You can find this under WooCommerce > Settings > Shipping > Shipping Zones. Shipping zones match customer address from top to bottom — the first to match the customer address is always used. Due to this, if you have your Shipping Zone set and something other than USPS is set first, such as Free Shipping or Flat Rate, it will go with that first and ignore USPS. To fix this if that is the case, edit the Shipping Zone and move USPS to the top by clicking the three bars next to it and moving it, as seen here.

    Please check this and let us know what you have if it is different, or did not work.

    Plugin Support yukikatayama

    (@yukikatayama)

    Automattic Happiness Engineer

    Hi @curiouslt,

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can’t get live USPS rates to work’ is closed to new replies.