Support » Plugin: WooCommerce Stripe Payment Gateway » Can’t get latest update to work

  • Resolved 286blue

    (@286blue)


    Hi there,

    I’ve rolled back to version 2.6.12 for now as I can’t get the latest update to work on a site.

    The site has the latest version of WordPress & Woocommerce, plus all relevant plugins have been updated, and the whole site is run on HTTPS via Really Simple SSL.

    With the latest update, for some reason, can’t click in the card input fields to enter credit card number & expiry date, etc.

    Initially, the input fields were very narrow so have styled them to be larger but still no ability to click and type into them.

    Have checked for error messages on page loading and the following appears:

    [Error] Failed to load resource: An SSL error has occurred and a secure connection to the server cannot be made. (v3, line 0)
    [Error] ReferenceError: Can’t find variable: Stripe (stripe-payment-request.min.js, line 1)

    Could this help to find the cause of the issue?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hi @286blue,

    Were you updating from WooCommerce 2.6.12 all the way to 3.7? Or are you updating Stripe from 2.6.12? Either way, that’s quite a big jump in versions. You will want to make sure that you also update all of your other plugins on the site(especially WooCommerce-related plugins) and make sure your theme is updated and compatible with the latest version of WooCommerce.

    With the latest update, for some reason, can’t click in the card input fields to enter credit card number & expiry date, etc.

    That is usually caused by a JavaScript error on the page. Make sure the Stripe plugin is fully updated and test with just WooCommerce 3.7 and the Stripe plugins activated as well as with a default theme(Storefront or 2019).

    Hi Thomas,

    It was a leap of Woocommerce versions but I tested it on another non-public installation and it worked great.

    All the plugins are updated apart from one which I’m in the process of trying to purchase via the Woocommerce site BUT I’m seeing the same issue on the Woocommerce checkout page where there’s a narrow white box that I can’t click into to enter credit card information to purchase it.

    Uploaded screenshot to http://286blue.com/woocommercecheckoutpage.jpg

    Aha, I think I’ve narrowed it down to a browser issue.

    It works on Chrome, Firefox, Waterfox, and the latest version of Safari but doesn’t work on older versions of Safari.

    I guess it’s for security reasons but it’s a shame to exclude shoppers who are using older technology who can’t or don’t want to update/pay for a new computer.

    Do you know if there’s a list somewhere of the browsers the plugin does / doesn’t support? I may add a note to the credit card box to inform shoppers who may be puzzled why they can’t enter their card details that they’re using an old browser.

    Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    What older version of Safari did you test on?

    I tested it an old mac running 10.7.something.

    Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    Can you provide a link to your site so that we can take a look?

    Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    Actually, there is no such thing as Safari 10.7. I think you are referring to OSX 10.7 which was released in 2011, so it’s safe to say that OS is no longer supported 8 years later.

    Safari 10 was released in 2016, and has not been updated since 2017, so if that is the browser you have, it’s safe to assume that is no longer supported as well. But, if you are using OSX 10.7, Safari may be even older.

    Yes, I tested it on an old mac running OS x 10.7.something with an old version of Safari (possibly 6? I’ve packed it away now). I know that shoppers should be using the latest supported systems but in reality, people hold on to devices, without updating them, longer that we think so I like to test if sites & plugins work across all systems rather than excluding potential business.

    BUT, if it’s the case that Stripe doesn’t have backwards compatibility to work with older browsers, so be it – I’ve advised that it’s more important for the checkout page to be SCA-ready in preparation for September 14th rather than working on older browsers (however nice that might be).

    Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    Do you have any questions on being SCA ready? We have some resources at https://woocommerce.com/posts/introducing-strong-customer-authentication-sca/

    Thanks for the SCA link Melinda.

    Am assuming the latest version of the Woocommerce Stripe Payment Gateway takes care of this?

    Plugin Support rossviviano

    (@rossviviano)

    Automattic Happiness Engineer

    Hi @286blue,

    Am assuming the latest version of the Woocommerce Stripe Payment Gateway takes care of this?

    Yup! Just make sure you keep Stripe updated, and we’ll take care of the rest.

    Best,

    Ross

    Hello. Reading this topic, do I have to assume that if I update to SCA payments, users that would want to pay by credit card on older computers that runs on OS 10.7 could not buy my products anymore ? Because of SCA 3DSecure ?
    Thank you by advance.

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hi there @raouldouglas

    I wanted to reply here to close this off.

    > do I have to assume that if I update to SCA payments, users that would want to pay by credit card on older computers that runs on OS 10.7 could not buy my products anymore ? Because of SCA 3DSecure ?

    In a general sense – yes, but the bigger discussion would be helping those people to update. Browsing the internet on an older device such as a Mac running OSX Lion isn’t secure, this isn’t related to our Stripe plugin, or even WooCommerce, but about internet security in general.

    Older versions of all software aren’t supported, and Mac OSX Lion is unsupported. An update to macOS Sierra is available for supported devices but again, this isn’t related to Stripe or WooCommerce.

    Thanks,

    dyslexicadvantage

    (@dyslexicadvantage)

    I’m having a similar problem with the Stripe plugin. It stopped working in the last few days. I updated Alora and am not sure if that’s the reason.

    https://www.dyslexicadvantage.org/wp-content/uploads/2019/10/Screen-Shot-2019-10-08-at-4.05.54-PM.jpg

    The page is here: https://www.dyslexicadvantage.org/checkout-2/

    Thanks for any suggestions.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.